DoS Vulnerability in ntpd-rs
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pendulum-project | ntpd-rs | 1.2.0 to before 1.6.2 | 1.6.2 | Patch available | CNA |
| — | ntpd-rs (crates.io) | 1.2.0 to before 1.6.2 | 1.6.2 | Patch available | GHSA-4855-q42w-5vr4 |
- ntpd-rs Vendorpendulum-project Affected 1.2.0 to before 1.6.2 Fixed in 1.6.2 Patch available CNA
- ntpd-rs (crates.io) Vendor— Affected 1.2.0 to before 1.6.2 Fixed in 1.6.2 Patch available GHSA-4855-q42w-5vr4
Remediation
- Fix · CNA ntpd-rs (pendulum-project) Fixed in 1.6.2
- Fix · GHSA-4855-q42w-5vr4 ntpd-rs (crates.io) Fixed in 1.6.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58066
- 2026-10-03 Alias added: GHSA-4855-q42w-5vr4
References
More pendulum-project vulnerabilities
- TI-2024-25763 Unlimited number of NTS-KE connections can crash ntpd-rs server CVSS 3.1HIGH 7.5
Sources
- CVE-2025-58066 · CVE Program
- CVE-2025-58066 · NVD
- FIRST EPSS
- GHSA-4855-q42w-5vr4 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-58066 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences