pREST has Systemic SQL Injection Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
pREST (PostgreSQL REST), is an API that delivers an application on top of a Postgres database. SQL injection is possible in versions prior to 2.0.0-rc3. The validation present in versions prior to 2.0.0-rc3 does not provide adequate protection from injection attempts. Version 2.0.0-rc3 contains a patch to mitigate such attempts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| prest | prest | before 2.0.0-rc3 | 2.0.0-rc3 | Patch available | CNA |
| — | github.com/prest/prest/v2 (Go) | all versions | — | No fix listed | GHSA-p46v-f2x8-qp98 |
- prest Vendorprest Affected before 2.0.0-rc3 Fixed in 2.0.0-rc3 Patch available CNA
- github.com/prest/prest/v2 (Go) Vendor— Affected all versions Fixed in — No fix listed GHSA-p46v-f2x8-qp98
Remediation
- Fix · CNA prest (prest) Fixed in 2.0.0-rc3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58450
- 2026-10-03 Alias added: GHSA-p46v-f2x8-qp98
References
Sources
- CVE-2025-58450 · CVE Program
- CVE-2025-58450 · NVD
- FIRST EPSS
- GHSA-p46v-f2x8-qp98 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences