Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Claude Code is an agentic coding tool. Due to an error in command parsing, versions prior to 1.0.105 were vulnerable to a bypass of the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| anthropics | claude-code | before 1.0.105 | 1.0.105 | Patch available | CNA |
| — | @anthropic-ai/claude-code (npm) | before 1.0.105 | 1.0.105 | Patch available | GHSA-qxfv-fcpc-w36x |
- claude-code Vendoranthropics Affected before 1.0.105 Fixed in 1.0.105 Patch available CNA
- @anthropic-ai/claude-code (npm) Vendor— Affected before 1.0.105 Fixed in 1.0.105 Patch available GHSA-qxfv-fcpc-w36x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:anthropic:claude_code:*:*:*:*:*:node.js:*:* | before 1.0.105 | Vulnerable | anthropics |
- cpe:2.3:a:anthropic:claude_code:*:*:*:*:*:node.js:*:* Versions before 1.0.105 Vulnerable ·anthropics
Remediation
- Fix · CNA claude-code (anthropics) Fixed in 1.0.105
- Fix · GHSA-qxfv-fcpc-w36x @anthropic-ai/claude-code (npm) Fixed in 1.0.105 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58764
- 2026-10-03 Alias added: GHSA-qxfv-fcpc-w36x
References
More anthropics Claude Code vulnerabilities
- TI-2025-40558 Claude Code Command Validation Bypass Allows Arbitrary Code Execution CVSS 4.0HIGH 8.7
- TI-2025-36683 Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email CVSS 4.0HIGH 8.7
- TI-2025-37066 Claude Code's startup trust dialog could lead to Command Execution attack CVSS 4.0HIGH 8.7
- TI-2026-17554 Claude Code Leaks Data via Malicious Environment Configuration Before Trust Confirmation CVSS 4.0MEDIUM 5.3
- TI-2025-40093 @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes CVSS 4.0HIGH 8.7
- TI-2025-34550 Claude Code echo command allowed bypass of user approval prompt for command execution CVSS 4.0HIGH 8.7
Sources
- CVE-2025-58764 · CVE Program
- CVE-2025-58764 · NVD
- FIRST EPSS
- GHSA-qxfv-fcpc-w36x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences