Infrahub allows authentication with deleted and expired API tokens
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| opsmill | infrahub | before 1.3.9; 1.4.0 to before 1.4.5 | 1.3.9, 1.4.5 | Patch available | CNA |
| — | infrahub-server (PyPI) | before 1.3.9 | 1.3.9 | Patch available | GHSA-v2p7-4pv4-3wwh |
| — | infrahub-server (PyPI) | 1.4.0 to before 1.4.5 | 1.4.5 | Patch available | GHSA-v2p7-4pv4-3wwh |
- infrahub Vendoropsmill Affected before 1.3.9; 1.4.0 to before 1.4.5 Fixed in 1.3.9, 1.4.5 Patch available CNA
- infrahub-server (PyPI) Vendor— Affected before 1.3.9 Fixed in 1.3.9 Patch available GHSA-v2p7-4pv4-3wwh
- infrahub-server (PyPI) Vendor— Affected 1.4.0 to before 1.4.5 Fixed in 1.4.5 Patch available GHSA-v2p7-4pv4-3wwh
Remediation
- Fix · CNA infrahub (opsmill) Fixed in 1.3.9, 1.4.5
- Fix · GHSA-v2p7-4pv4-3wwh infrahub-server (PyPI) Fixed in 1.3.9 Advisory →
- Fix · GHSA-v2p7-4pv4-3wwh infrahub-server (PyPI) Fixed in 1.4.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59036
- 2026-10-03 Alias added: GHSA-v2p7-4pv4-3wwh
References
Other 6
- https://github.com/opsmill/infrahub/security/advisories/GHSA-v2p7-4pv4-3wwh
- https://github.com/opsmill/infrahub/commit/215185f217e2f754f7c0a0aa4b77e11079a063a1
- https://github.com/opsmill/infrahub/commit/61b49a4a9e988f10c3a44f0e86ef97f344a1e228
- https://github.com/opsmill/infrahub
- https://github.com/opsmill/infrahub/releases/tag/infrahub-v1.3.9
- https://github.com/opsmill/infrahub/releases/tag/infrahub-v1.4.5
Sources
- CVE-2025-59036 · CVE Program
- CVE-2025-59036 · NVD
- FIRST EPSS
- GHSA-v2p7-4pv4-3wwh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences