DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-506.
Summary
DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/[email protected]`, `@duckdb/[email protected]`, `[email protected]`, and `@duckdb/[email protected]` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| duckdb | duckdb-node | = 1.3.3; = 1.29.2 | — | No fix listed | CNA |
| — | duckdb (npm) | 1.3.3 to before 1.3.4 | 1.3.4 | Patch available | GHSA-w62p-hx95-gf2c |
| — | @duckdb/node-api (npm) | 1.3.3 to before 1.3.4-alpha.27 | 1.3.4-alpha.27 | Patch available | GHSA-w62p-hx95-gf2c |
| — | @duckdb/node-bindings (npm) | 1.3.3 to before 1.3.4-alpha.27 | 1.3.4-alpha.27 | Patch available | GHSA-w62p-hx95-gf2c |
| — | @duckdb/duckdb-wasm (npm) | 1.29.2 to before 1.30.0 | 1.30.0 | Patch available | GHSA-w62p-hx95-gf2c |
- duckdb-node Vendorduckdb Affected = 1.3.3; = 1.29.2 Fixed in — No fix listed CNA
- duckdb (npm) Vendor— Affected 1.3.3 to before 1.3.4 Fixed in 1.3.4 Patch available GHSA-w62p-hx95-gf2c
- @duckdb/node-api (npm) Vendor— Affected 1.3.3 to before 1.3.4-alpha.27 Fixed in 1.3.4-alpha.27 Patch available GHSA-w62p-hx95-gf2c
- @duckdb/node-bindings (npm) Vendor— Affected 1.3.3 to before 1.3.4-alpha.27 Fixed in 1.3.4-alpha.27 Patch available GHSA-w62p-hx95-gf2c
- @duckdb/duckdb-wasm (npm) Vendor— Affected 1.29.2 to before 1.30.0 Fixed in 1.30.0 Patch available GHSA-w62p-hx95-gf2c
Remediation
- Fix · GHSA-w62p-hx95-gf2c duckdb (npm) Fixed in 1.3.4 Advisory →
- Fix · GHSA-w62p-hx95-gf2c @duckdb/node-api (npm) Fixed in 1.3.4-alpha.27 Advisory →
- Fix · GHSA-w62p-hx95-gf2c @duckdb/node-bindings (npm) Fixed in 1.3.4-alpha.27 Advisory →
- Fix · GHSA-w62p-hx95-gf2c @duckdb/duckdb-wasm (npm) Fixed in 1.30.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59037
- 2026-10-03 Alias added: GHSA-w62p-hx95-gf2c
References
More duckdb vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2024-27733 DuckDB: sniff_csv provides filesystem access even when enable_external_access is disabled CVSS 3.1HIGH 7.5
- TI-2025-39842 DuckDB Encryption Crypto implementation is vulnerable CVSS 4.0MEDIUM 6.9
- TI-2026-41861 DuckDB AWS Extension Security Policy Bypass via load_aws_credentials Procedure CVSS 4.0MEDIUM 6.0
Sources
- CVE-2025-59037 · CVE Program
- CVE-2025-59037 · NVD
- FIRST EPSS
- GHSA-w62p-hx95-gf2c · GitHub Advisory Database · CC BY 4.0
- CVE-2025-59037 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences