Read the docs
TI-2025-36690 Aliases CVE-2025-59048GHSA-jp7h-4f3c-9rc7

OpenBao AWS Plugin Vulnerable to Cross-Account IAM Role Impersonation in AWS Auth Method

Priority LOW 35CWE-694Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin. A workaround for this issue involves guaranteeing that IAM role names are unique across all AWS accounts that could potentially interact with your OpenBao environment, and to audit for any duplicate IAM roles.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00266 18th percentileScored 2026-11-07
Fix Fixed openbao-plugins (openbao): 0.1.1github.com/openbao/openbao-plugins (Go): 0.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
openbaoopenbao-pluginsbefore 0.1.10.1.1Patch availableCNA
—github.com/openbao/openbao-plugins (Go)before 0.1.10.1.1Patch availableGHSA-jp7h-4f3c-9rc7
  • openbao-plugins Vendoropenbao Affected before 0.1.1 Fixed in 0.1.1 Patch available CNA
  • github.com/openbao/openbao-plugins (Go) Vendor— Affected before 0.1.1 Fixed in 0.1.1 Patch available GHSA-jp7h-4f3c-9rc7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:openbao:aws_plugin:*:*:*:*:*:*:*:*before 0.1.1Vulnerableopenbao
  • cpe:2.3:a:openbao:aws_plugin:*:*:*:*:*:*:*:* Versions before 0.1.1 Vulnerable ·openbao

Remediation

  • Fix · CNA openbao-plugins (openbao) Fixed in 0.1.1
  • Fix · GHSA-jp7h-4f3c-9rc7 github.com/openbao/openbao-plugins (Go) Fixed in 0.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59048
  2. 2026-10-03 Alias added: GHSA-jp7h-4f3c-9rc7

References

Sources