Apache CloudStack: Potential remote code execution on Javascript engine defined rules
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-94.
Summary
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache CloudStack | 4.18.0 to before 4.20.2; 4.21.0 to before 4.22.0 | 4.20.2, 4.22.0 | Patch available | CNA |
- Apache CloudStack VendorApache Affected 4.18.0 to before 4.20.2; 4.21.0 to before 4.22.0 Fixed in 4.20.2, 4.22.0 Patch available CNA
Remediation
- Fix · CNA Apache CloudStack (Apache Software Foundation) Fixed in 4.20.2, 4.22.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache CloudStack 4.20.2, 4.22.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-36999 Apache CloudStack: Lack of user permission validation leading to data leak for few APIsPriority LOW 20
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59302
- 2026-10-03 Alias added: GHSA-hgmv-qpw9-xrfq
References
More Apache Cloudstack vulnerabilities
- TI-2024-27459 Apache CloudStack: SAML Signature Exclusion CVSS 3.1HIGH 8.1
- TI-2024-25607 Apache CloudStack: Unauthenticated cluster service port leads to remote execution CVSS 3.1CRITICAL 9.8
- TI-2022-16183 Apache CloudStack SAML Single Sign-On XXE CVSS 3.1CRITICAL 9.8
- TI-2012-03843 Citrix Cloud.com CloudStack, and Apache CloudStack pre-release, allows remote attackers… CVSS 2.0HIGH 10.0
- TI-2024-26763 Apache CloudStack: Integration API service uses dynamic port when disabled CVSS 3.1CRITICAL 9.8
- TI-2016-05854 Apache CloudStack 4.1 to 4.8.1.0 and 4.9.0.0 contain an API call designed to allow a user… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-59302 · CVE Program
- CVE-2025-59302 · NVD
- FIRST EPSS
- GHSA-hgmv-qpw9-xrfq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences