HAProxy Kubernetes Ingress Controller before 3.1.13, when the config-snippets feature…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
HAProxy Kubernetes Ingress Controller before 3.1.13, when the config-snippets feature flag is used, accepts config snippets from users with create/update permissions. This can result in obtaining an ingress token secret as a response. The fixed versions of HAProxy Enterprise Kubernetes Ingress Controller are 3.0.16-ee1, 1.11.13-ee1, and 1.9.15-ee1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA HAProxy Kubernetes Ingress Controller (HAProxy) Fixed in 3.1.13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 5 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Not affected: 2 products
- Red Hat Hardened Images
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59303
- 2026-10-03 Alias added: GHSA-jf49-m4qc-cf6c
References
More HAProxy vulnerabilities
- TI-2020-08973 In hpack_dht_insert in hpack-tbl.c in the HPACK decoder in HAProxy 1.8 through 2.x before… CVSS 3.1HIGH 8.8
- TI-2023-21094 HAProxy through 2.0.32, 2.1.x and 2.2.x through 2.2.30, 2.3.x and 2.4.x through 2.4.23… CVSS 3.1HIGH 7.2
- TI-2019-10602 HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via… CVSS 3.0HIGH 7.5
- TI-2021-17418 An integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be… CVSS 3.1HIGH 7.5
- TI-2016-04651 HAproxy 1.6.x before 1.6.6, when a deny comes from a reqdeny rule, allows remote… CVSS 3.0HIGH 7.5
- TI-2026-25946 An issue was discovered in HAProxy before 3.3.6. CVSS 3.1MEDIUM 5.8
Sources
- CVE-2025-59303 · CVE Program
- CVE-2025-59303 · NVD
- FIRST EPSS
- GHSA-jf49-m4qc-cf6c · GitHub Advisory Database · CC BY 4.0
- CVE-2025-59303 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences