libvips is vulnerable to Buffer Over-Read in poppler-based pdfload
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA libvips (libvips) Fixed in 8.17.2
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59933
References
More Libvips vulnerabilities
- TI-2026-02835 libvips extract.c vips_extract_area_build integer overflow CVSS 4.0MEDIUM 4.8
- TI-2026-02834 libvips extract.c vips_extract_band_build out-of-bounds CVSS 4.0MEDIUM 4.8
- TI-2026-02833 libvips unpremultiply.c vips_unpremultiply_build out-of-bounds CVSS 4.0MEDIUM 4.8
- TI-2026-02832 libvips bandrank.c vips_bandrank_build heap-based overflow CVSS 4.0MEDIUM 4.8
- TI-2026-02719 libvips csvload.c vips_foreign_load_csv_build heap-based overflow CVSS 4.0MEDIUM 4.8
- TI-2026-02718 libvips matrixload.c vips_foreign_load_matrix_header null pointer dereference CVSS 4.0MEDIUM 4.8
Sources
- CVE-2025-59933 · CVE Program
- CVE-2025-59933 · NVD
- FIRST EPSS
- CVE-2025-59933 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences