mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders
Priority LOW 35CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00341 27th percentileScored 2026-11-07
Fix Partial mkdocs-include-markdown-plugin (mondeja): 7.1.8mkdocs-include-markdown-plugin (PyPI): 7.1.8Red Hat: 3 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mondeja | mkdocs-include-markdown-plugin | before 7.1.8 | 7.1.8 | Patch available | CNA |
| — | mkdocs-include-markdown-plugin (PyPI) | before 7.1.8 | 7.1.8 | Patch available | GHSA-v39m-5m9j-m9w9 |
- mkdocs-include-markdown-plugin Vendormondeja Affected before 7.1.8 Fixed in 7.1.8 Patch available CNA
- mkdocs-include-markdown-plugin (PyPI) Vendor— Affected before 7.1.8 Fixed in 7.1.8 Patch available GHSA-v39m-5m9j-m9w9
Remediation
- Fix · CNA mkdocs-include-markdown-plugin (mondeja) Fixed in 7.1.8
- Fix · GHSA-v39m-5m9j-m9w9 mkdocs-include-markdown-plugin (PyPI) Fixed in 7.1.8 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Assisted Installer for Red Hat OpenShift Container Platform 2 | Affected | No fix yet: Fix deferred |
| Multicluster Engine for Kubernetes | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59940
- 2026-10-03 Alias added: GHSA-v39m-5m9j-m9w9
References
Other 5
- https://github.com/mondeja/mkdocs-include-markdown-plugin/security/advisories/GHSA-v39m-5m9j-m9w9
- https://github.com/mondeja/mkdocs-include-markdown-plugin/issues/274
- https://github.com/mondeja/mkdocs-include-markdown-plugin/pull/277
- https://github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915
- https://github.com/mondeja/mkdocs-include-markdown-plugin
Sources
- CVE-2025-59940 · CVE Program
- CVE-2025-59940 · NVD
- FIRST EPSS
- GHSA-v39m-5m9j-m9w9 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-59940 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences