Sanitizer::validateAttributes data-XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki, Wikimedia Foundation Parsoid. This vulnerability is associated with program files includes/parser/Sanitizer.Php, src/Core/Sanitizer.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1; Parsoid: from * before 0.16.6, 0.20.4, 0.21.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | before 1.39.14, 1.43.4, 1.44.1 | 1.39.14, 1.43.4, 1.44.1 | Patch available | CNA |
| Wikimedia Foundation | Parsoid | before 0.16.6, 0.20.4, 0.21.1 | 0.16.6, 0.20.4, 0.21.1 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected before 1.39.14, 1.43.4, 1.44.1 Fixed in 1.39.14, 1.43.4, 1.44.1 Patch available CNA
- Parsoid VendorWikimedia Foundation Affected before 0.16.6, 0.20.4, 0.21.1 Fixed in 0.16.6, 0.20.4, 0.21.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | before 1.39.14; 1.39.15 to before 1.43.4; 1.43.5 to before 1.44.1 | Vulnerable | mediawiki |
| cpe:2.3:a:wikimedia:parsoid:*:*:*:*:*:node.js:*:* | before 0.16.6; after 0.16.6, before 0.20.4; after 0.20.4, before 0.21.1 | Vulnerable | Wikimedia Foundation |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions before 1.39.14; 1.39.15 to before 1.43.4; 1.43.5 to before 1.44.1 Vulnerable ·mediawiki
- cpe:2.3:a:wikimedia:parsoid:*:*:*:*:*:node.js:*:* Versions before 0.16.6; after 0.16.6, before 0.20.4; after 0.20.4, before 0.21.1 Vulnerable ·Wikimedia Foundation
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.39.14, 1.43.4, 1.44.1
- Fix · CNA Parsoid (Wikimedia Foundation) Fixed in 0.16.6, 0.20.4, 0.21.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation MediaWiki 1.39.14, 1.43.4, 1.44.1
9 records Highest priority Priority LOW 9 LOW
Other records, highest priority first
- TI-2025-38077 EventStreams publishes suppressed recent change entries that are suppressed from their creationPriority LOW 19
- TI-2025-38075 API list=allpages with maxsize is making really slow queriesPriority LOW 9
- TI-2025-38073 Suppressed blocked IP is visible in Special:BlockList, RC, and other placesPriority LOW 9
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-61638
- 2026-10-03 Alias added: GHSA-mq9h-r82m-hvhc
References
More Wikimedia Foundation Parsoid vulnerabilities
- TI-2021-10863 An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-61638 · CVE Program
- CVE-2025-61638 · NVD
- FIRST EPSS
- GHSA-mq9h-r82m-hvhc · GitHub Advisory Database · CC BY 4.0
- CVE-2025-61638 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences