Stored XSS through system messages in VisualEditor
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files includes/ApiVisualEditorEdit.Php, modules/ve-mw/init/targets/ve.Init.Mw.DesktopArticleTarget.Js, modules/ve-mw/ui/dialogs/ve.Ui.MWSaveDialog.Js. This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | VisualEditor | before 1.39.14, 1.43.4, 1.44.1 | 1.39.14, 1.43.4, 1.44.1 | Patch available | CNA |
- VisualEditor VendorWikimedia Foundation Affected before 1.39.14, 1.43.4, 1.44.1 Fixed in 1.39.14, 1.43.4, 1.44.1 Patch available CNA
Remediation
- Fix · CNA VisualEditor (Wikimedia Foundation) Fixed in 1.39.14, 1.43.4, 1.44.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation VisualEditor 1.39.14, 1.43.4, 1.44.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-38090 XSS when pasting into VEPriority LOW 2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-61655
- 2026-10-03 Alias added: GHSA-5gh3-pm42-f6qp
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-61655 · CVE Program
- CVE-2025-61655 · NVD
- FIRST EPSS
- GHSA-5gh3-pm42-f6qp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences