Read the docs
TI-2025-38266 Aliases CVE-2025-61916GHSA-vrjc-q2fh-6x9h

Spinnaker vulnerable to SSRF due to improper restrictions on http from user input

Priority LOW 34CWE-20Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Spinnaker is an open source, multi-cloud continuous delivery platform. Versions prior to 2025.1.6, 2025.2.3, and 2025.3.0 are vulnerable to server-side request forgery. The primary impact is allowing users to fetch data from a remote URL. This data can be then injected into spinnaker pipelines via helm or other methods to extract things LIKE idmsv1 authentication data. This also includes calling internal spinnaker API's via a get and similar endpoints. Further, depending upon the artifact in question, auth data may be exposed to arbitrary endpoints (e.g. GitHub auth headers) leading to credentials exposure. To trigger this, a spinnaker installation MUST have two things. The first is an artifact enabled that allows user input. This includes GitHub file artifacts, BitBucket, GitLab, HTTP artifacts and similar artifact providers. JUST enabling the http artifact provider will add a "no-auth" http provider that could be used to extract link local data (e.g. AWS Metadata information). The second is a system that can consume the output of these artifacts. e.g. Rosco helm can use this to fetch values data. K8s account manifests if the API returns JSON can be used to inject that data into the pipeline itself though the pipeline would fail. This vulnerability is fixed in versions 2025.1.6, 2025.2.3, and 2025.3.0. As a workaround, disable HTTP account types that allow user input of a given URL. This is probably not feasible in most cases. Git, Docker and other artifact account types with explicit URL configurations bypass this limitation and should be safe as they limit artifact URL loading. Alternatively, use one of the various vendors which provide OPA policies to restrict pipelines from accessing or saving a pipeline with invalid URLs.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0017 6th percentileScored 2026-11-07
Fix Fixed spinnaker (spinnaker): 2025.1.6, 2025.2.3io.spinnaker.clouddriver:clouddriver-artifacts (Maven): 2025.1.6, 2025.2.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
spinnakerspinnakerbefore 2025.1.6; 2025.2.0 to before 2025.2.32025.1.6, 2025.2.3Patch availableCNA
—io.spinnaker.clouddriver:clouddriver-artifacts (Maven)before 2025.1.62025.1.6Patch availableGHSA-vrjc-q2fh-6x9h
—io.spinnaker.clouddriver:clouddriver-artifacts (Maven)2025.2.0 to before 2025.2.32025.2.3Patch availableGHSA-vrjc-q2fh-6x9h
  • spinnaker Vendorspinnaker Affected before 2025.1.6; 2025.2.0 to before 2025.2.3 Fixed in 2025.1.6, 2025.2.3 Patch available CNA
  • io.spinnaker.clouddriver:clouddriver-artifacts (Maven) Vendor— Affected before 2025.1.6 Fixed in 2025.1.6 Patch available GHSA-vrjc-q2fh-6x9h
  • io.spinnaker.clouddriver:clouddriver-artifacts (Maven) Vendor— Affected 2025.2.0 to before 2025.2.3 Fixed in 2025.2.3 Patch available GHSA-vrjc-q2fh-6x9h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:linuxfoundation:spinnaker:*:*:*:*:*:*:*:*before 2025.1.6; 2025.2.0 to before 2025.2.3Vulnerablebackstage
  • cpe:2.3:a:linuxfoundation:spinnaker:*:*:*:*:*:*:*:* Versions before 2025.1.6; 2025.2.0 to before 2025.2.3 Vulnerable ·backstage

Remediation

  • Fix · CNA spinnaker (spinnaker) Fixed in 2025.1.6, 2025.2.3
  • Fix · GHSA-vrjc-q2fh-6x9h io.spinnaker.clouddriver:clouddriver-artifacts (Maven) Fixed in 2025.1.6 Advisory →
  • Fix · GHSA-vrjc-q2fh-6x9h io.spinnaker.clouddriver:clouddriver-artifacts (Maven) Fixed in 2025.2.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-61916
  2. 2026-10-03 Alias added: GHSA-vrjc-q2fh-6x9h

References

  • TI-2021-16529 Path Traversal in spinnaker CVSS 3.1HIGH 7.1
  • TI-2021-19638 Improper Access Control in spinnaker CVSS 3.1CRITICAL 10.0
  • TI-2026-25122 Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling CVSS 3.1CRITICAL 10.0
  • TI-2026-25113 Improper input validation in spinnaker CVSS 3.1CRITICAL 10.0
  • TI-2026-32679 Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types CVSS 3.1HIGH 8.8
  • TI-2026-39859 Spinnaker: Improper yaml processing on kustomize bake operations CVSS 3.1HIGH 7.5
See all 9 →

Sources