ImageMagick vulnerable to denial of service via integer overflow in BMP decoder on 32-bit systems
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
ImageMagick is an open source software suite for displaying, converting, and editing raster image files. In ImageMagick versions prior to 7.1.2-7 and 6.9.13-32, an integer overflow vulnerability exists in the BMP decoder on 32-bit systems. The vulnerability occurs in coders/bmp.c when calculating the extent value by multiplying image columns by bits per pixel. On 32-bit systems with size_t of 4 bytes, a malicious BMP file with specific dimensions can cause this multiplication to overflow and wrap to zero. The overflow check added to address CVE-2025-57803 is placed after the overflow occurs, making it ineffective. A specially crafted 58-byte BMP file with width set to 536,870,912 and 32 bits per pixel can trigger this overflow, causing the bytes_per_line calculation to become zero. This vulnerability only affects 32-bit builds of ImageMagick where default resource limits for width, height, and area have been manually increased beyond their defaults. 64-bit systems with size_t of 8 bytes are not vulnerable, and systems using default ImageMagick resource limits are not vulnerable. The vulnerability is fixed in versions 7.1.2-7 and 6.9.13-32.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ImageMagick | ImageMagick | before 6.9.13-32; 7.0.0-0 to before 7.1.2-7 | 6.9.13-32, 7.1.2-7 | Patch available | CNA |
| — | Magick.NET-Q16-AnyCPU (NuGet) | before 14.9.0 | 14.9.0 | Patch available | GHSA-9pp9-cfwx-54rm |
| — | Magick.NET-Q16-HDRI-AnyCPU (NuGet) | before 14.9.0 | 14.9.0 | Patch available | GHSA-9pp9-cfwx-54rm |
| — | Magick.NET-Q16-HDRI-x86 (NuGet) | before 14.9.0 | 14.9.0 | Patch available | GHSA-9pp9-cfwx-54rm |
| — | Magick.NET-Q16-x86 (NuGet) | before 14.9.0 | 14.9.0 | Patch available | GHSA-9pp9-cfwx-54rm |
| — | Magick.NET-Q8-AnyCPU (NuGet) | before 14.9.0 | 14.9.0 | Patch available | GHSA-9pp9-cfwx-54rm |
| — | Magick.NET-Q8-x86 (NuGet) | before 14.9.0 | 14.9.0 | Patch available | GHSA-9pp9-cfwx-54rm |
- ImageMagick VendorImageMagick Affected before 6.9.13-32; 7.0.0-0 to before 7.1.2-7 Fixed in 6.9.13-32, 7.1.2-7 Patch available CNA
- Magick.NET-Q16-AnyCPU (NuGet) Vendor— Affected before 14.9.0 Fixed in 14.9.0 Patch available GHSA-9pp9-cfwx-54rm
- Magick.NET-Q16-HDRI-AnyCPU (NuGet) Vendor— Affected before 14.9.0 Fixed in 14.9.0 Patch available GHSA-9pp9-cfwx-54rm
- Magick.NET-Q16-HDRI-x86 (NuGet) Vendor— Affected before 14.9.0 Fixed in 14.9.0 Patch available GHSA-9pp9-cfwx-54rm
- Magick.NET-Q16-x86 (NuGet) Vendor— Affected before 14.9.0 Fixed in 14.9.0 Patch available GHSA-9pp9-cfwx-54rm
- Magick.NET-Q8-AnyCPU (NuGet) Vendor— Affected before 14.9.0 Fixed in 14.9.0 Patch available GHSA-9pp9-cfwx-54rm
- Magick.NET-Q8-x86 (NuGet) Vendor— Affected before 14.9.0 Fixed in 14.9.0 Patch available GHSA-9pp9-cfwx-54rm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* | before 6.9.13-32; 7.0.0-0 to before 7.1.2-7 | Vulnerable | ImageMagick |
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* Versions before 6.9.13-32; 7.0.0-0 to before 7.1.2-7 Vulnerable ·ImageMagick
Remediation
- Fix · CNA ImageMagick (ImageMagick) Fixed in 6.9.13-32, 7.1.2-7
- Fix · GHSA-9pp9-cfwx-54rm Magick.NET-Q16-AnyCPU (NuGet) Fixed in 14.9.0 Advisory →
- Fix · GHSA-9pp9-cfwx-54rm Magick.NET-Q16-HDRI-AnyCPU (NuGet) Fixed in 14.9.0 Advisory →
- Fix · GHSA-9pp9-cfwx-54rm Magick.NET-Q16-HDRI-x86 (NuGet) Fixed in 14.9.0 Advisory →
- Fix · GHSA-9pp9-cfwx-54rm Magick.NET-Q16-x86 (NuGet) Fixed in 14.9.0 Advisory →
- Fix · GHSA-9pp9-cfwx-54rm Magick.NET-Q8-AnyCPU (NuGet) Fixed in 14.9.0 Advisory →
- Fix · GHSA-9pp9-cfwx-54rm Magick.NET-Q8-x86 (NuGet) Fixed in 14.9.0 Advisory →
Red Hat 1 advisory
- RHSA-2026:3058 Released 2026-02-23 · Red Hat rating ImportantImageMagick security update
- Red Hat Enterprise Linux Server (v. 7 ELS) ImageMagick-6.9.10.68-10.el7_9, ImageMagick-6.9.10.68-10.el7_9.ppc, ImageMagick-c++-6.9.10.68-10.el7_9 +1
- Red Hat Enterprise Linux Server Optional (v. 7 ELS) ImageMagick-c++-6.9.10.68-10.el7_9, ImageMagick-c++-6.9.10.68-10.el7_9.ppc, ImageMagick-c++-devel-6.9.10.68-10.el7_9 +4
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux Server (v. 7 ELS) | Fixed | RHSA-2026:3058 |
| Red Hat Enterprise Linux Server Optional (v. 7 ELS) | Fixed | RHSA-2026:3058 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62171
- 2026-10-03 Alias added: GHSA-9pp9-cfwx-54rm
References
More Imagemagick vulnerabilities
- TI-2016-03144 The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT… KEVCVSS 3.1HIGH 8.4
- TI-2023-16996 Improper input validation in ImageMagick CVSS 3.1CRITICAL 9.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2025-35690 ImageMagick BlobStream Forward-Seek Under-Allocation CVSS 3.1CRITICAL 9.8
- TI-2025-33094 ImageMagick has Stack Buffer Overflow in image.c CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-62171 · CVE Program
- CVE-2025-62171 · NVD
- FIRST EPSS
- GHSA-9pp9-cfwx-54rm · GitHub Advisory Database · CC BY 4.0
- CVE-2025-62171 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences