DataEase vulnerable to JDBC URL injection in DB2 and MongoDB data source configuration
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
DataEase is a data visualization and analytics platform. In DataEase versions through 2.10.13, a JDBC URL injection vulnerability exists in the DB2 and MongoDB data source configuration handlers. In the DB2 data source handler, when the extraParams field is empty, the HOSTNAME, PORT, and DATABASE values are directly concatenated into the JDBC URL without filtering illegal parameters. This allows an attacker to inject a malicious JDBC string into the HOSTNAME field to bypass previously patched vulnerabilities CVE-2025-57773 and CVE-2025-58045. The vulnerability is fixed in version 2.10.14. No known workarounds exist.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA dataease (dataease) Fixed in 2.10.14
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62419
References
More Dataease vulnerabilities
- TI-2024-38037 An issue in DataEase v1 allows an attacker to execute arbitrary code via the user account and password components. CVSS 3.1CRITICAL 9.8
- TI-2023-12981 SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed CVSS 3.1CRITICAL 9.8
- TI-2022-18688 Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-24677 Dataease: Redshift JDBC RCE Bypass CVSS 4.0CRITICAL 9.3
- TI-2026-24674 DataEase SQL Injection Vulnerability CVSS 4.0CRITICAL 9.3
- TI-2024-37398 DataEase has an unauthorized vulnerability CVSS 4.0CRITICAL 9.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences