Citizen vulnerable to stored XSS in sticky header button messages
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Citizen from 3.3.0 to 3.9.0 are vulnerable to stored cross-site scripting in the sticky header button message handling. In stickyHeader.js the copyButtonAttributes function assigns innerHTML from a source element’s textContent when copying button labels. This causes escaped HTML in system message content (such as citizen-share, citizen-view-history, citizen-view-edit, and nstab-talk) to be interpreted as HTML in the sticky header, allowing injection of arbitrary script by a user with the ability to edit interface messages. The vulnerability allows a user with the editinterface right but without the editsitejs right (by default the sysop group has editinterface but may not have editsitejs) to execute arbitrary JavaScript in other users’ sessions, enabling unauthorized access to sensitive data or actions. The issue is fixed in 3.9.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| StarCitizenTools | mediawiki-skins-Citizen | 3.3.0 to before 3.9.0 | 3.9.0 | Patch available | CNA |
| — | starcitizentools/citizen-skin (Packagist) | 3.3.0 to before 3.9.0 | 3.9.0 | Patch available | GHSA-g955-vw6w-v6pp |
- mediawiki-skins-Citizen VendorStarCitizenTools Affected 3.3.0 to before 3.9.0 Fixed in 3.9.0 Patch available CNA
- starcitizentools/citizen-skin (Packagist) Vendor— Affected 3.3.0 to before 3.9.0 Fixed in 3.9.0 Patch available GHSA-g955-vw6w-v6pp
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:starcitizen.tools:citizen:*:*:*:*:*:*:*:* | — | — | StarCitizenTools |
- cpe:2.3:a:starcitizen.tools:citizen:*:*:*:*:*:*:*:* Versions — — ·StarCitizenTools
Remediation
- Fix · CNA mediawiki-skins-Citizen (StarCitizenTools) Fixed in 3.9.0
- Fix · GHSA-g955-vw6w-v6pp starcitizentools/citizen-skin (Packagist) Fixed in 3.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62508
- 2026-10-03 Alias added: GHSA-g955-vw6w-v6pp
References
Other 4
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-g955-vw6w-v6pp
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/e006923c6dbf113c9a025ca186ecc09fe7b93a15
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/fbb1d4fe9627281567706f3f6fc99a42ce16fdc4
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen
More StarCitizenTools vulnerabilities
- TI-2025-33331 Citizen Short Description stored XSS vulnerability through wikitext CVSS 3.1HIGH 8.6
- TI-2025-33330 Citizen is vulnerable to stored XSS attack in the legacy search bar CVSS 3.1HIGH 8.6
- TI-2025-33086 TabberNeue vulnerable to Stored XSS through wikitext CVSS 3.1HIGH 8.6
- TI-2025-15572 Cross-site Scripting in TabberTransclude in Extension:TabberNeue CVSS 3.1HIGH 8.6
- TI-2025-33332 Citizen stored XSS vulnerability through short descriptions CVSS 3.1HIGH 8.6
- TI-2024-23953 Citizen has a Stored Cross-Site Scripting Vulnerability by editing MediaWiki:Tagline CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-62508 · CVE Program
- CVE-2025-62508 · NVD
- FIRST EPSS
- GHSA-g955-vw6w-v6pp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences