Read the docs
TI-2025-38903 Aliases CVE-2025-62713GHSA-j3w7-9qc3-g96p

Kottster app reinitialization can be re-triggered allowing command injection in development mode

Priority LOW 35CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass, Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284 and CWE-78.

Summary

Kottster is a self hosted Node.js admin panel. From versions 3.2.0 to before 3.3.2, Kottster contains a pre-authentication remote code execution (RCE) vulnerability when running in development mode. This affects development mode only, production deployments were never affected. This issue has been fixed in version 3.3.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00609 49th percentileScored 2026-11-07
Fix Fixed kottster (kottster): 3.3.2@kottster/server (npm): 3.3.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
kottsterkottster3.2.0 to before 3.3.23.3.2Patch availableCNA
—@kottster/server (npm)3.2.0 to before 3.3.23.3.2Patch availableGHSA-j3w7-9qc3-g96p
  • kottster Vendorkottster Affected 3.2.0 to before 3.3.2 Fixed in 3.3.2 Patch available CNA
  • @kottster/server (npm) Vendor— Affected 3.2.0 to before 3.3.2 Fixed in 3.3.2 Patch available GHSA-j3w7-9qc3-g96p

Remediation

  • Fix · CNA kottster (kottster) Fixed in 3.3.2
  • Fix · GHSA-j3w7-9qc3-g96p @kottster/server (npm) Fixed in 3.3.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-62713
  2. 2026-10-03 Alias added: GHSA-j3w7-9qc3-g96p

References

Sources