Apache Hive: SQL injection vulnerability when processing delete column statistics requests via the HMS Thrift APIs
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false. This issue affects Apache Hive: from 4.1.0 before 4.2.0. Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Hive | 4.1.0 to before 4.2.0 | 4.2.0 | Patch available | CNA |
| — | org.apache.hive:hive-common (Maven) | 4.1.0 to before 4.2.0 | 4.2.0 | Patch available | GHSA-932v-x9x2-vq29 |
| — | org.apache.hive:hive-metastore (Maven) | 4.1.0 to before 4.2.0 | 4.2.0 | Patch available | GHSA-932v-x9x2-vq29 |
- Apache Hive VendorApache Affected 4.1.0 to before 4.2.0 Fixed in 4.2.0 Patch available CNA
- org.apache.hive:hive-common (Maven) Vendor— Affected 4.1.0 to before 4.2.0 Fixed in 4.2.0 Patch available GHSA-932v-x9x2-vq29
- org.apache.hive:hive-metastore (Maven) Vendor— Affected 4.1.0 to before 4.2.0 Fixed in 4.2.0 Patch available GHSA-932v-x9x2-vq29
Remediation
- Fix · CNA Apache Hive (Apache Software Foundation) Fixed in 4.2.0
- Fix · GHSA-932v-x9x2-vq29 org.apache.hive:hive-common (Maven) Fixed in 4.2.0 Advisory →
- Fix · GHSA-932v-x9x2-vq29 org.apache.hive:hive-metastore (Maven) Fixed in 4.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62728
- 2026-10-03 Alias added: GHSA-932v-x9x2-vq29
References
Advisory 3
More Apache Hive vulnerabilities
- TI-2018-15196 Jodd before 5.0.4 performs Deserialization of Untrusted JSON Data when setClassMetadataName is set. CVSS 3.1CRITICAL 9.8
- TI-2026-40376 Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url CVSS 3.1CRITICAL 9.1
- TI-2018-01187 SQL injection in Apache Hive CVSS 3.0CRITICAL 9.1
- TI-2026-36749 Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths CVSS 3.1CRITICAL 9.8
- TI-2015-06259 The authorization framework in Apache Hive 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0 and 1.2.1… CVSS 3.0HIGH 8.3
- TI-2020-10925 Uncontrolled resource consumption in Apache Thrift CVSS 3.1HIGH 7.5
Sources
- CVE-2025-62728 · CVE Program
- CVE-2025-62728 · NVD
- FIRST EPSS
- GHSA-932v-x9x2-vq29 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences