FastDDS has Out-of-memory in readOctetVector via Manipulated DATA Submessage when DDS Security is enabled
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group ). Prior to versions 3.4.1, 3.3.1, and 2.6.11, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If t he fields of `PID_IDENTITY_TOKEN` or `PID_PERMISSIONS_TOKEN` in the DATA Submessage are tampered with — specifically by ta mpering with the the `vecsize` value read by `readOctetVector` — a 32-bit integer overflow can occur, causing `std::vector ::resize` to request an attacker-controlled size and quickly trigger OOM and remote process termination. Versions 3.4.1, 3 .3.1, and 2.6.11 patch the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| eProsima | Fast-DDS | 3.4.0 to before 3.4.1; 3.0.0 to before 3.3.1; before 2.6.11 | 3.4.1, 3.3.1, 2.6.11 | Patch available | CNA |
- Fast-DDS VendoreProsima Affected 3.4.0 to before 3.4.1; 3.0.0 to before 3.3.1; before 2.6.11 Fixed in 3.4.1, 3.3.1, 2.6.11 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:* | before 2.6.11; 3.0.0 to before 3.3.1 | Vulnerable | eProsima |
| cpe:2.3:a:eprosima:fast_dds:3.4.0:*:*:*:*:*:*:* | 3.4.0 | Vulnerable | eProsima |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* | 12.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:13.0:*:*:*:*:*:*:* | 13.0 | Vulnerable | Debian |
- cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:* Versions before 2.6.11; 3.0.0 to before 3.3.1 Vulnerable ·eProsima
- cpe:2.3:a:eprosima:fast_dds:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·eProsima
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:13.0:*:*:*:*:*:*:* Versions 13.0 Vulnerable ·Debian
Remediation
- Fix · CNA Fast-DDS (eProsima) Fixed in 3.4.1, 3.3.1, 2.6.11
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
eProsima Fast-DDS 2.6.11, 3.3.1, 3.4.1
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2025-38982 FastDDS's heap buffer overflow in RTPS DATA_FRAG enables unauthenticated DoS (potential RCE)Priority LOW 34
- TI-2025-38818 FastDDS has Out-of-memory while parsing GenericMessage when DDS Security is enabledPriority LOW 16
- TI-2025-38817 FastDDS has heap buffer overflow in readData via Manipulated DATA Submessage when DDS Security is enabledPriority LOW 16
Timeline
- 2026-10-02 Threatist record created from CVE-2025-64098
References
Patch 3
More eProsima Fast Dds vulnerabilities
- TI-2025-38815 Integer overflow in eProsima Fast-DDS CVSS 3.1HIGH 8.6
- TI-2024-18790 Manipulated DATA Submessage causes a heap-buffer-overflow error CVSS 3.1CRITICAL 9.7
- TI-2023-27485 Disconnect Vulnerability in RTPS Packets Used by SROS2 CVSS 3.1CRITICAL 9.7
- TI-2024-20005 FastDDS heap buffer overflow when publisher sends malformed packet CVSS 3.1HIGH 8.2
- TI-2023-20840 Another heap overflow in push_back_helper CVSS 3.1HIGH 8.2
- TI-2023-20839 Heap overflow in push_back_helper due to a CDR message CVSS 3.1HIGH 8.2
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences