OpenMage is vulnerable to XSS in Admin Notifications
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenMage | magento-lts | before 20.16.0 | 20.16.0 | Patch available | CNA |
| — | openmage/magento-lts (Packagist) | before 20.16.0 | 20.16.0 | Patch available | GHSA-qv78-c8hc-438r |
- magento-lts VendorOpenMage Affected before 20.16.0 Fixed in 20.16.0 Patch available CNA
- openmage/magento-lts (Packagist) Vendor— Affected before 20.16.0 Fixed in 20.16.0 Patch available GHSA-qv78-c8hc-438r
Remediation
- Fix · CNA magento-lts (OpenMage) Fixed in 20.16.0
- Fix · GHSA-qv78-c8hc-438r openmage/magento-lts (Packagist) Fixed in 20.16.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-64174
- 2026-10-03 Alias added: GHSA-qv78-c8hc-438r
References
More OpenMage Magento vulnerabilities
- TI-2026-20633 OpenMage LTS's Phar Deserialization leads to Remote Code Execution CVSS 3.1HIGH 8.1
- TI-2026-29239 OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution CVSS 4.0HIGH 8.7
- TI-2023-22272 Magento LTS's guest order "protect code" can be brute-forced too easily CVSS 3.1HIGH 7.5
- TI-2026-28925 Missing authorization in OpenMage magento-lts CVSS 4.0MEDIUM 5.3
- TI-2026-20634 OpenMage LTS has Path Traversal Filter Bypass in Dataflow Module CVSS 3.1MEDIUM 4.9
- TI-2021-04494 Magneto-lts vulnerable to Cross-Site Request Forgery CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-64174 · CVE Program
- CVE-2025-64174 · NVD
- FIRST EPSS
- GHSA-qv78-c8hc-438r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences