Read the docs
TI-2025-40099 Aliases CVE-2025-64761GHSA-7ff4-jw48-3436

OpenBao Privileged Operator Identity Group Root Escalation

Priority LOW 35CWE-266Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-266.

Summary

OpenBao is an open source identity-based secrets management system. Prior to version 2.4.4, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: an operator in the root namespace has access to identity/groups endpoints and an operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. This issue has been patched in version 2.4.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0039 33rd percentileScored 2026-11-07
Fix Fixed openbao (openbao): 2.4.4github.com/openbao/openbao (Go): 2.4.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
openbaoopenbaobefore 2.4.42.4.4Patch availableCNA
—github.com/openbao/openbao (Go)before 2.4.42.4.4Patch availableGHSA-7ff4-jw48-3436
  • openbao Vendoropenbao Affected before 2.4.4 Fixed in 2.4.4 Patch available CNA
  • github.com/openbao/openbao (Go) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-7ff4-jw48-3436

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:openbao:openbao:*:*:*:*:*:*:*:*before 2.4.4Vulnerableopenbao
  • cpe:2.3:a:openbao:openbao:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·openbao

Remediation

  • Fix · CNA openbao (openbao) Fixed in 2.4.4
  • Fix · GHSA-7ff4-jw48-3436 github.com/openbao/openbao (Go) Fixed in 2.4.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-64761
  2. 2026-10-03 Alias added: GHSA-7ff4-jw48-3436

References

  • TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
  • TI-2026-28381 OpenBao has Decompression Bomb via Unbounded Copy in OCI Plugin Extraction (DoS) CVSS 3.1MEDIUM 6.5
  • TI-2026-26136 OpenBao lacks user confirmation for OIDC direct callback mode CVSS 3.1CRITICAL 9.6
  • TI-2026-26137 OpenBao has Reflected XSS in its OIDC authentication error message CVSS 4.0CRITICAL 9.4
  • TI-2025-34701 OpenBao: Privileged Operator May Execute Code on the Underlying Host CVSS 3.1CRITICAL 9.1
  • TI-2025-36685 OpenBao vulnerable to denial of service via malicious JSON request processing CVSS 3.1HIGH 7.5
See all 24 →

Sources