Read the docs
TI-2025-40199 Aliases CVE-2025-65012GHSA-84hf-8gh5-575j

Kirby CMS has cross-site scripting (XSS) in the changes dialog

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the "Changes" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00196 9th percentileScored 2026-11-07
Fix Fixed kirby (getkirby): 5.1.4getkirby/cms (Packagist): 5.1.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getkirbykirby5.0.0 to before 5.1.45.1.4Patch availableCNA
—getkirby/cms (Packagist)5.0.0 to before 5.1.45.1.4Patch availableGHSA-84hf-8gh5-575j
  • kirby Vendorgetkirby Affected 5.0.0 to before 5.1.4 Fixed in 5.1.4 Patch available CNA
  • getkirby/cms (Packagist) Vendor— Affected 5.0.0 to before 5.1.4 Fixed in 5.1.4 Patch available GHSA-84hf-8gh5-575j

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*5.0.0 to before 5.1.4Vulnerablegetkirby
  • cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.1.4 Vulnerable ·getkirby

Remediation

  • Fix · CNA kirby (getkirby) Fixed in 5.1.4
  • Fix · GHSA-84hf-8gh5-575j getkirby/cms (Packagist) Fixed in 5.1.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-65012
  2. 2026-10-03 Alias added: GHSA-84hf-8gh5-575j

References

  • TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
  • TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
  • TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
  • TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
  • TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
  • TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
See all 40 →

Sources