Windscribe for Linux 'changeMTU' local privilege escalation
Priority LOW 37CWE-78Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01253 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Windscribe for Linux Desktop App (Windscribe): 2.18.3-alpha, 2.18.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Windscribe | Windscribe for Linux Desktop App | 2.10.1 to before 2.18.3-alpha; 2.10.1 to before 2.18.8 | 2.18.3-alpha, 2.18.8 | Patch available | CNA |
- Windscribe for Linux Desktop App VendorWindscribe Affected 2.10.1 to before 2.18.3-alpha; 2.10.1 to before 2.18.8 Fixed in 2.18.3-alpha, 2.18.8 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:windscribe:windscribe:*:*:*:*:*:linux:*:* | 2.10.1 – 2.17.10 | Vulnerable | Windscribe |
| cpe:2.3:a:windscribe:windscribe:2.18.1:alpha:*:*:*:linux:*:* | 2.18.1 alpha | Vulnerable | Windscribe |
| cpe:2.3:a:windscribe:windscribe:2.18.3:*:*:*:*:linux:*:* | 2.18.3 | Vulnerable | Windscribe |
| cpe:2.3:a:windscribe:windscribe:2.18.5:*:*:*:*:linux:*:* | 2.18.5 | Vulnerable | Windscribe |
- cpe:2.3:a:windscribe:windscribe:*:*:*:*:*:linux:*:* Versions 2.10.1 – 2.17.10 Vulnerable ·Windscribe
- cpe:2.3:a:windscribe:windscribe:2.18.1:alpha:*:*:*:linux:*:* Versions 2.18.1 alpha Vulnerable ·Windscribe
- cpe:2.3:a:windscribe:windscribe:2.18.3:*:*:*:*:linux:*:* Versions 2.18.3 Vulnerable ·Windscribe
- cpe:2.3:a:windscribe:windscribe:2.18.5:*:*:*:*:linux:*:* Versions 2.18.5 Vulnerable ·Windscribe
Remediation
- Fix · CNA Windscribe for Linux Desktop App (Windscribe) Fixed in 2.18.3-alpha, 2.18.8
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65199
- 2026-10-03 Alias added: GHSA-842w-c8vj-r24w
More Windscribe vulnerabilities
- TI-2018-08203 The VPN component in Windscribe 1.81 uses the OpenVPN client for connections. CVSS 3.0HIGH 7.8
- TI-2024-05690 Path traversal in Windscribe CVSS 3.1HIGH 7.8
- TI-2022-19660 Uncontrolled search path in Windscribe CVSS 3.1HIGH 7.8
- TI-2020-16687 All versions of Windscribe VPN for Mac and Windows <= v2.02.10 contain a local privilege… CVSS 3.1HIGH 7.8
- TI-2020-14401 In Windscribe v1.83 Build 20, 'WindscribeService' has an Unquoted Service Path that facilitates privilege escalation. CVSS 3.1HIGH 7.8
- TI-2018-08079 Windscribe 1.81 creates a named pipe with a NULL DACL that allows Everyone users to gain… CVSS 3.0HIGH 7.8
Sources
- CVE-2025-65199 · CVE Program
- CVE-2025-65199 · NVD
- FIRST EPSS
- GHSA-842w-c8vj-r24w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences