NeuVector OpenID Connect is vulnerable to man-in-the-middle (MITM)
Priority MEDIUM 40CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
NeuVector supports login authentication through OpenID Connect. However, the TLS verification (which verifies the remote server's authenticity and integrity) for OpenID Connect is not enforced by default. As a result this may expose the system to man-in-the-middle (MITM) attacks.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00361 30th percentileScored 2026-11-07
Fix Fixed neuvector (SUSE): 5.4.8github.com/neuvector/neuvector (Go): 5.4.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | neuvector | 5.3.0 to before 5.4.8 | 5.4.8 | Patch available | CNA |
| — | github.com/neuvector/neuvector (Go) | 5.3.0 to before 5.4.8 | 5.4.8 | Patch available | GHSA-4jj9-cgqc-x9h5 |
- neuvector VendorSUSE Affected 5.3.0 to before 5.4.8 Fixed in 5.4.8 Patch available CNA
- github.com/neuvector/neuvector (Go) Vendor— Affected 5.3.0 to before 5.4.8 Fixed in 5.4.8 Patch available GHSA-4jj9-cgqc-x9h5
Remediation
- Fix · CNA neuvector (SUSE) Fixed in 5.4.8
- Fix · GHSA-4jj9-cgqc-x9h5 github.com/neuvector/neuvector (Go) Fixed in 5.4.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-66001
- 2026-10-03 Alias added: GHSA-4jj9-cgqc-x9h5
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-66001 · CVE Program
- CVE-2025-66001 · NVD
- FIRST EPSS
- GHSA-4jj9-cgqc-x9h5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences