Read the docs
TI-2025-40550 Aliases CVE-2025-66024GHSA-h2xq-h7f9-vh6c

XWiki Blog Application home page vulnerable to Stored XSS via Post Title

Priority HIGH 70CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00439 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed application-blog-ui (xwiki-contrib): 9.15.7org.xwiki.contrib.blog:application-blog-ui (Maven): 9.15.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
XWikiapplication-blog-ui9.15 to before 9.15.79.15.7Patch availableCNA
—org.xwiki.contrib.blog:application-blog-ui (Maven)9.15 to before 9.15.79.15.7Patch availableGHSA-h2xq-h7f9-vh6c
  • application-blog-ui VendorXWiki Affected 9.15 to before 9.15.7 Fixed in 9.15.7 Patch available CNA
  • org.xwiki.contrib.blog:application-blog-ui (Maven) Vendor— Affected 9.15 to before 9.15.7 Fixed in 9.15.7 Patch available GHSA-h2xq-h7f9-vh6c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:xwiki:blog_application:*:*:*:*:*:*:*:*before 9.15.7VulnerableXWiki
  • cpe:2.3:a:xwiki:blog_application:*:*:*:*:*:*:*:* Versions before 9.15.7 Vulnerable ·XWiki

Remediation

  • Fix · CNA application-blog-ui (xwiki-contrib) Fixed in 9.15.7
  • Fix · GHSA-h2xq-h7f9-vh6c org.xwiki.contrib.blog:application-blog-ui (Maven) Fixed in 9.15.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-66024
  2. 2026-10-03 Alias added: GHSA-h2xq-h7f9-vh6c

References

Sources