Read the docs
TI-2025-40720 Aliases CVE-2025-66217

AIS-catcher Integer Underflow in MQTT Packet Parsing leading to Heap Buffer Overflow

Priority HIGH 77CWE-122Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manipulated Topic Length field. This leads to an immediate Denial of Service (DoS) and, when used as a library, severe Memory Corruption that can be leveraged for Remote Code Execution (RCE). This issue has been patched in version 0.64.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00778 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed AIS-catcher (jvde-github): 0.64

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
jvde-githubAIS-catcherbefore 0.640.64Patch availableCNA
  • AIS-catcher Vendorjvde-github Affected before 0.64 Fixed in 0.64 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:aiscatcher:ais-catcher:*:*:*:*:*:*:*:*before 0.64VulnerableAiscatcher
  • cpe:2.3:a:aiscatcher:ais-catcher:*:*:*:*:*:*:*:* Versions before 0.64 Vulnerable ·Aiscatcher

Remediation

  • Fix · CNA AIS-catcher (jvde-github) Fixed in 0.64

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-66217

References

  • TI-2025-40719 AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE CVSS 4.0CRITICAL 9.3

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences