Read the docs
TI-2025-40864 Aliases CVE-2025-66431GHSA-mp85-3986-vf9p

WebPros Plesk before 18.0.73.5 and 18.0.74 before 18.0.74.2 on Linux allows remote…

Priority LOW 36CWE-61Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

WebPros Plesk before 18.0.73.5 and 18.0.74 before 18.0.74.2 on Linux allows remote authenticated users to execute arbitrary code as root via domain creation. The attacker needs "Create and manage sites" with "Domains management" and "Subdomains management."

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00269 19th percentileScored 2026-11-07
Fix Fixed Plesk (Plesk): 18.0.73.5, 18.0.74.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PleskPleskbefore 18.0.73.5; 18.0.74 to before 18.0.74.218.0.73.5, 18.0.74.2Patch availableCNA
  • Plesk VendorPlesk Affected before 18.0.73.5; 18.0.74 to before 18.0.74.2 Fixed in 18.0.73.5, 18.0.74.2 Patch available CNA

Remediation

  • Fix · CNA Plesk (Plesk) Fixed in 18.0.73.5, 18.0.74.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-66431
  2. 2026-10-03 Alias added: GHSA-mp85-3986-vf9p

References

  • TI-2021-20370 Plesk 18.0.37 is affected by a Cross Site Request Forgery (CSRF) vulnerability that… CVSS 3.1MEDIUM 6.5
  • TI-2023-09824 A Host Header Injection issue on the Login page of Plesk Obsidian through 18.0.49 allows… CVSS 3.1MEDIUM 6.1
  • TI-2025-40863 Plesk 18.0 has Incorrect Access Control. CVSS 3.1CRITICAL 9.1
  • TI-2021-20371 Plesk CMS 18.0.37 is affected by an insecure permissions vulnerability that allows… CVSS 3.1HIGH 8.8
  • TI-2023-00785 Cross-Site Scripting (XSS) vulnerability in Plesk CVSS 3.1CRITICAL 9.0
  • TI-2023-23475 Plesk Onyx 17.8.11 has accessKeyId and secretAccessKey fields that are related to an… CVSS 3.1HIGH 7.5
See all 13 →

Sources