Read the docs
TI-2025-40888 Aliases CVE-2025-66456GHSA-hxj9-33pp-j2cc

Elysia vulnerable to prototype pollution with multiple standalone schema validation

Priority HIGH 74CWE-1321Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.0 through 1.4.16 contain a prototype pollution vulnerability in `mergeDeep` after merging results of two standard schema validations with the same key. Due to the ordering of merging, there must be an any type that is set as a standalone guard, to allow for the `__proto__ prop` to be merged. When combined with GHSA-8vch-m3f4-q8jf this allows for a full RCE by an attacker. This issue is fixed in version 1.4.17. To workaround, remove the `__proto__ key` from body.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0056 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed elysia (elysiajs): 1.4.17elysia (npm): 1.4.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
elysiajselysia1.4.0 to before 1.4.171.4.17Patch availableCNA
—elysia (npm)1.4.0 to before 1.4.171.4.17Patch availableGHSA-hxj9-33pp-j2cc
  • elysia Vendorelysiajs Affected 1.4.0 to before 1.4.17 Fixed in 1.4.17 Patch available CNA
  • elysia (npm) Vendor— Affected 1.4.0 to before 1.4.17 Fixed in 1.4.17 Patch available GHSA-hxj9-33pp-j2cc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elysiajs:elysia:*:*:*:*:*:node.js:*:*1.4.0 to before 1.4.17Vulnerableelysiajs
  • cpe:2.3:a:elysiajs:elysia:*:*:*:*:*:node.js:*:* Versions 1.4.0 to before 1.4.17 Vulnerable ·elysiajs

Remediation

  • Fix · CNA elysia (elysiajs) Fixed in 1.4.17
  • Fix · GHSA-hxj9-33pp-j2cc elysia (npm) Fixed in 1.4.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-66456
  2. 2026-10-03 Alias added: GHSA-hxj9-33pp-j2cc

References

  • TI-2025-40889 Elysia affected by arbitrary code injection through cookie config CVSS 4.0HIGH 7.5
  • TI-2026-23666 Elysia has a string URL format redos CVSS 3.1HIGH 7.5
  • TI-2026-24417 Elysia Cookie Value Prototype Pollution CVSS 3.1MEDIUM 6.5

Sources