XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XWiki | xwiki-rendering | before 16.10.10; 17.0.0-rc-1 to before 17.4.3; 17.5.0-rc-1 to before 17.6.0-rc-1 | 16.10.10, 17.4.3, 17.6.0-rc-1 | Patch available | CNA |
| — | org.xwiki.rendering:xwiki-rendering-xml (Maven) | before 16.10.10 | 16.10.10 | Patch available | GHSA-9xc6-c2rm-f27p |
| — | org.xwiki.rendering:xwiki-rendering-xml (Maven) | 17.0.0-rc-1 to before 17.4.3 | 17.4.3 | Patch available | GHSA-9xc6-c2rm-f27p |
| — | org.xwiki.rendering:xwiki-rendering-xml (Maven) | 17.5.0-rc-1 to before 17.6.0-rc-1 | 17.6.0-rc-1 | Patch available | GHSA-9xc6-c2rm-f27p |
- xwiki-rendering VendorXWiki Affected before 16.10.10; 17.0.0-rc-1 to before 17.4.3; 17.5.0-rc-1 to before 17.6.0-rc-1 Fixed in 16.10.10, 17.4.3, 17.6.0-rc-1 Patch available CNA
- org.xwiki.rendering:xwiki-rendering-xml (Maven) Vendor— Affected before 16.10.10 Fixed in 16.10.10 Patch available GHSA-9xc6-c2rm-f27p
- org.xwiki.rendering:xwiki-rendering-xml (Maven) Vendor— Affected 17.0.0-rc-1 to before 17.4.3 Fixed in 17.4.3 Patch available GHSA-9xc6-c2rm-f27p
- org.xwiki.rendering:xwiki-rendering-xml (Maven) Vendor— Affected 17.5.0-rc-1 to before 17.6.0-rc-1 Fixed in 17.6.0-rc-1 Patch available GHSA-9xc6-c2rm-f27p
CPE configurations NVD · 3
Remediation
- Fix · CNA xwiki-rendering (xwiki) Fixed in 16.10.10, 17.4.3, 17.6.0-rc-1
- Fix · GHSA-9xc6-c2rm-f27p org.xwiki.rendering:xwiki-rendering-xml (Maven) Fixed in 16.10.10 Advisory →
- Fix · GHSA-9xc6-c2rm-f27p org.xwiki.rendering:xwiki-rendering-xml (Maven) Fixed in 17.4.3 Advisory →
- Fix · GHSA-9xc6-c2rm-f27p org.xwiki.rendering:xwiki-rendering-xml (Maven) Fixed in 17.6.0-rc-1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-66474
- 2026-10-03 Alias added: GHSA-9xc6-c2rm-f27p
References
Exploit 3
Patch 4
More Xwiki-rendering vulnerabilities
- TI-2023-19345 XWiki Rendering's footnote macro vulnerable to privilege escalation via the footnote macro CVSS 3.1CRITICAL 10.0
- TI-2023-19341 Cross-site scripting in xwiki-rendering CVSS 3.1CRITICAL 9.6
- TI-2026-19446 XWiki Affected by Reflected Cross-Site Scripting (XSS) in Error Messages CVSS 4.0MEDIUM 6.5
Sources
- CVE-2025-66474 · CVE Program
- CVE-2025-66474 · NVD
- FIRST EPSS
- GHSA-9xc6-c2rm-f27p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences