Dive has Cross-Site Scripting vulnerability that can escalate to Remote Code Execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution, Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94 and CWE-79.
Summary
Dive is an open-source MCP Host Desktop Application that enables integration with function-calling LLMs. A critical Stored Cross-Site Scripting (XSS) vulnerability exists in versions prior to 0.11.1 in the Mermaid diagram rendering component. The application allows the execution of arbitrary JavaScript via `javascript:`. An attacker can exploit this to inject a malicious Model Context Protocol (MCP) server configuration, leading to Remote Code Execution (RCE) on the victim's machine when the node is clicked. Version 0.11.1 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenAgentPlatform | Dive | before 0.11.1 | 0.11.1 | Patch available | CNA |
- Dive VendorOpenAgentPlatform Affected before 0.11.1 Fixed in 0.11.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openagentplatform:dive:*:*:*:*:*:*:*:* | before 0.11.1 | Vulnerable | OpenAgentPlatform |
- cpe:2.3:a:openagentplatform:dive:*:*:*:*:*:*:*:* Versions before 0.11.1 Vulnerable ·OpenAgentPlatform
Remediation
- Fix · CNA Dive (OpenAgentPlatform) Fixed in 0.11.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-66580
References
More OpenAgentPlatform Dive vulnerabilities
- TI-2026-18947 Dive allows One-click Remote Code Execution through Deep Links for MCP Install CVSS 3.1CRITICAL 9.7
- TI-2025-35984 Dive's improper processing of custom urls can lead to Remote Code Execution CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences