Lantronix EDS5000 OS Command Injection
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
An issue was discovered in Lantronix EDS5000 2.1.0.0R3. The SSH Client and SSH Server pages are affected by multiple OS injection vulnerabilities due to missing sanitization of input parameters. An attacker can inject arbitrary commands in delete actions of various objects, such as server keys, users, and known hosts. Commands are executed with root privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Lantronix | EDS5000 series | up to 2.1.0.0R3 | 2.2.0.0R1 | Patch available | CNA |
- EDS5000 series VendorLantronix Affected up to 2.1.0.0R3 Fixed in 2.2.0.0R1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:lantronix:eds5032_firmware:2.1.0.0r3:*:*:*:*:*:*:* | 2.1.0.0r3 | Vulnerable | Lantronix |
| cpe:2.3:h:lantronix:eds5032:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lantronix |
| cpe:2.3:o:lantronix:eds5008_firmware:2.1.0.0r3:*:*:*:*:*:*:* | 2.1.0.0r3 | Vulnerable | Lantronix |
| cpe:2.3:h:lantronix:eds5008:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lantronix |
| cpe:2.3:o:lantronix:eds5016_firmware:2.1.0.0r3:*:*:*:*:*:*:* | 2.1.0.0r3 | Vulnerable | Lantronix |
| cpe:2.3:h:lantronix:eds5016:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lantronix |
- cpe:2.3:o:lantronix:eds5032_firmware:2.1.0.0r3:*:*:*:*:*:*:* Versions 2.1.0.0r3 Vulnerable ·Lantronix
- cpe:2.3:h:lantronix:eds5032:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lantronix
- cpe:2.3:o:lantronix:eds5008_firmware:2.1.0.0r3:*:*:*:*:*:*:* Versions 2.1.0.0r3 Vulnerable ·Lantronix
- cpe:2.3:h:lantronix:eds5008:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lantronix
- cpe:2.3:o:lantronix:eds5016_firmware:2.1.0.0r3:*:*:*:*:*:*:* Versions 2.1.0.0r3 Vulnerable ·Lantronix
- cpe:2.3:h:lantronix:eds5016:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lantronix
Remediation
- Fix · CNA EDS5000 series (Lantronix) Fixed in 2.2.0.0R1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67035
- 2026-10-03 Alias added: GHSA-rxgf-4wqv-5r9g
References
Other 2
- https://www.lantronix.com/technical-support/security-updates/vulnerability-disclosure-policy/vulnerability-library/?_gl=16c8bez_upMQ.._gaMzQwNjk5ODI5LjE3ODI5MTM3NTk._ga_M2G6RLT5L3*czE3ODI5MTM3NTgkbzEkZzAkdDE3ODI5MTM3NTgkajYwJGwwJGgw
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-069-02.json
More Lantronix Eds5008 Firmware vulnerabilities
- TI-2025-41112 Lantronix EDS5000, G520, and X300 OS Command Injection KEVCVSS 4.0CRITICAL 9.3
- TI-2025-41111 Lantronix EDS5000, G520, and X300 OS Command Injection CVSS 4.0HIGH 8.6
- TI-2025-41110 Lantronix EDS5000, G520, and X300 OS Command Injection CVSS 4.0HIGH 8.6
- TI-2025-41108 Lantronix EDS5000, G520, and X300 OS Command Injection CVSS 4.0HIGH 8.6
Sources
- CVE-2025-67035 · CVE Program
- CVE-2025-67035 · NVD
- FIRST EPSS
- GHSA-rxgf-4wqv-5r9g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences