Stored XSS through a system message in Special:ApiSandbox
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Special.Apisandbox/ApiSandboxLayout.Js. This issue affects MediaWiki: from * before 1.44.3, 1.45.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | before 1.44.3, 1.45.1 | 1.44.3, 1.45.1 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected before 1.44.3, 1.45.1 Fixed in 1.44.3, 1.45.1 Patch available CNA
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.44.3, 1.45.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation MediaWiki 1.44.3, 1.45.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-41235 Importing leaks IP address of importer via EventStreamsPriority LOW 8
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67477
- 2026-10-03 Alias added: GHSA-p9cm-3vjx-2fr4
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-67477 · CVE Program
- CVE-2025-67477 · NVD
- FIRST EPSS
- GHSA-p9cm-3vjx-2fr4 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-67477 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences