Read the docs
TI-2025-41384 Aliases CVE-2025-67641GHSA-v3f3-rf6r-43x5

Cross-site scripting in Jenkins Coverage Plugin

Priority LOW 35CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Coverage Plugin 2.3054.ve1ff7b_a_a_123b_ and earlier does not validate the configured coverage results ID when creating coverage results, only when submitting the job configuration through the UI, allowing attackers with Item/Configure permission to use a `javascript:` scheme URL as identifier by configuring the job through the REST API, resulting in a stored cross-site scripting (XSS) vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00307 23rd percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:coverage (Maven): 2.3056

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Coverage Pluginup to 2.3054.ve1ff7b_a_a_123b_—No fix listedCNA
—io.jenkins.plugins:coverage (Maven)before 2.30562.3056Patch availableGHSA-v3f3-rf6r-43x5
  • Jenkins Coverage Plugin VendorJenkins Affected up to 2.3054.ve1ff7b_a_a_123b_ Fixed in — No fix listed CNA
  • io.jenkins.plugins:coverage (Maven) Vendor— Affected before 2.3056 Fixed in 2.3056 Patch available GHSA-v3f3-rf6r-43x5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:coverage:*:*:*:*:*:jenkins:*:*up to 2.3054.ve1ff7b_a_a_123bVulnerableJenkins
  • cpe:2.3:a:jenkins:coverage:*:*:*:*:*:jenkins:*:* Versions up to 2.3054.ve1ff7b_a_a_123b Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-v3f3-rf6r-43x5 io.jenkins.plugins:coverage (Maven) Fixed in 2.3056 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67641
  2. 2026-10-03 Alias added: GHSA-v3f3-rf6r-43x5

References

Sources