Read the docs
TI-2025-41419 Aliases CVE-2025-67723

Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00217 12th percentileScored 2026-11-07
Fix Fixed discourse (discourse): 3.5.4, 2025.11.2, 2025.12.1 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
discoursediscoursebefore 3.5.4; 2025.11.0-latest to before 2025.11.2; 2025.12.0-latest to before 2025.12.1; 2026.1.0-latest to before 2026.1.03.5.4, 2025.11.2, 2025.12.1, 2026.1.0Patch availableCNA
  • discourse Vendordiscourse Affected before 3.5.4; 2025.11.0-latest to before 2025.11.2; 2025.12.0-latest to before 2025.12.1; 2026.1.0-latest to before 2026.1.0 Fixed in 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*before 3.5.4; 2025.11.0 to before 2025.11.2Vulnerablediscourse
cpe:2.3:a:discourse:discourse:2025.12.0:*:*:*:stable:*:*:*2025.12.0Vulnerablediscourse
  • cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:* Versions before 3.5.4; 2025.11.0 to before 2025.11.2 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:2025.12.0:*:*:*:stable:*:*:* Versions 2025.12.0 Vulnerable ·discourse

Remediation

  • Fix · CNA discourse (discourse) Fixed in 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67723

References

  • TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
  • TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
  • TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
  • TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
  • TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
  • TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
See all 262 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences