Servify Express does not enforce rate limiting when parsing JSON
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser without limits and exposed to untrusted clients is affected. The issue is not a flaw in Express itself, but in configuration. This issue is fixed in version 1.2. To work around, consider adding a limit option to the JSON parser, rate limiting at the application or reverse-proxy level, rejecting unusually large requests before parsing, or using a reverse proxy (such as NGINX) to enforce maximum request body sizes.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Aarondoran | servify-express | before 1.2 | 1.2 | Patch available | CNA |
| — | servify-express (npm) | before 1.2 | 1.2 | Patch available | GHSA-qgc4-8p88-4w7m |
- servify-express VendorAarondoran Affected before 1.2 Fixed in 1.2 Patch available CNA
- servify-express (npm) Vendor— Affected before 1.2 Fixed in 1.2 Patch available GHSA-qgc4-8p88-4w7m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:servify-express.js:servify_express:*:*:*:*:*:node.js:*:* | before 1.2 | Vulnerable | Servify-express.js |
- cpe:2.3:a:servify-express.js:servify_express:*:*:*:*:*:node.js:*:* Versions before 1.2 Vulnerable ·Servify-express.js
Remediation
- Fix · CNA servify-express (Aarondoran) Fixed in 1.2
- Fix · GHSA-qgc4-8p88-4w7m servify-express (npm) Fixed in 1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67731
- 2026-10-03 Alias added: GHSA-qgc4-8p88-4w7m
References
Patch 1
Advisory 2
Sources
- CVE-2025-67731 · CVE Program
- CVE-2025-67731 · NVD
- FIRST EPSS
- GHSA-qgc4-8p88-4w7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences