Composer vulnerable to ANSI sequence injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| composer | composer | 2.0 to before 2.2.26; 2.3 to before 2.9.3 | 2.2.26, 2.9.3 | Patch available | CNA |
| — | composer/composer (Packagist) | 2.0.0 to before 2.2.26 | 2.2.26 | Patch available | GHSA-59pp-r3rg-353g |
| — | composer/composer (Packagist) | 2.3.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-59pp-r3rg-353g |
- composer Vendorcomposer Affected 2.0 to before 2.2.26; 2.3 to before 2.9.3 Fixed in 2.2.26, 2.9.3 Patch available CNA
- composer/composer (Packagist) Vendor— Affected 2.0.0 to before 2.2.26 Fixed in 2.2.26 Patch available GHSA-59pp-r3rg-353g
- composer/composer (Packagist) Vendor— Affected 2.3.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-59pp-r3rg-353g
Remediation
- Fix · CNA composer (composer) Fixed in 2.2.26, 2.9.3
- Fix · GHSA-59pp-r3rg-353g composer/composer (Packagist) Fixed in 2.2.26 Advisory →
- Fix · GHSA-59pp-r3rg-353g composer/composer (Packagist) Fixed in 2.9.3 Advisory →
Red Hat 1 advisory
- RHSA-2026:8165 Released 2026-04-14 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images composer-2.9.7-1.hum1@noarch@public-hummingbird-aarch64-rpms, composer-2.9.7-1.hum1@noarch@public-hummingbird-x86_64-rpms, composer-2.9.7-1.hum1@src
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Hardened Images | Fixed | RHSA-2026:8165 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67746
- 2026-10-03 Alias added: GHSA-59pp-r3rg-353g
References
Patch 2
Advisory 2
More Composer vulnerabilities
- TI-2015-06892 Composer before 2016-02-10 allows cache poisoning from other projects built on the same… CVSS 3.1HIGH 8.8
- TI-2021-17955 Command injection in composer on Windows CVSS 3.1CRITICAL 9.8
- TI-2021-10185 Code injection in composer CVSS 3.1HIGH 8.8
- TI-2022-08641 Missing input validation can lead to command execution in composer CVSS 3.1HIGH 8.8
- TI-2026-29055 Composer has Command Injection via Malicious Perforce Reference CVSS 3.1HIGH 8.8
- TI-2023-23380 Remote Code Execution via web-accessible composer.phar CVSS 3.1HIGH 8.8
Sources
- CVE-2025-67746 · CVE Program
- CVE-2025-67746 · NVD
- FIRST EPSS
- GHSA-59pp-r3rg-353g · GitHub Advisory Database · CC BY 4.0
- CVE-2025-67746 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences