A crafted "interface" input parameter can lead to integrity loss of the firewall configuration
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-88.
Summary
A Improper Neutralization of Argument Delimiters vulnerability in Foomuuri can lead to integrity loss of the firewall configuration or further unspecified impact by manipulating the JSON configuration passed to `nft`. This issue affects Foomuuri: from ? before 0.31.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| https://github.com/FoobarOy/ | Foomuuri | ? to before 0.31 | 0.31 | Patch available | CNA |
- Foomuuri Vendorhttps://github.com/FoobarOy/ Affected ? to before 0.31 Fixed in 0.31 Patch available CNA
Remediation
- Fix · CNA Foomuuri (https://github.com/FoobarOy/) Fixed in 0.31
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
https://github.com/FoobarOy/ Foomuuri 0.31
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-41355 Lack of client authorization allows arbitrary users to influence the firewall configurationPriority LOW 22
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67858
- 2026-10-03 Alias added: GHSA-hjvr-2r84-cx23
References
More https://github.com/FoobarOy/ vulnerabilities
- TI-2025-41355 Lack of client authorization allows arbitrary users to influence the firewall configuration CVSS 4.0MEDIUM 5.1
Sources
- CVE-2025-67858 · CVE Program
- CVE-2025-67858 · NVD
- FIRST EPSS
- GHSA-hjvr-2r84-cx23 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-67858 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences