Read the docs
TI-2025-41508 Aliases CVE-2025-67895GHSA-66h8-3g48-6hx8

Apache Airflow Providers Edge3: Edge3 Worker RPC RCE on Airflow 2

Priority MEDIUM 51CWE-669Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Edge3 Worker RPC RCE on Airflow 2. This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if you installed and configured it on Airflow 2. The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if you installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do. If you installed and configured Edge3 provider for Airflow 2, you should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2. If you used Edge Provider in Airflow 3, you are not affected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01168 67th percentileScored 2026-11-07
Fix Fixed Apache Airflow Providers Edge3 (Apache Software Foundation): 2.0.0apache-airflow-providers-edge3 (PyPI): 2.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflow Providers Edge3before 2.0.02.0.0Patch availableCNA
—apache-airflow-providers-edge3 (PyPI)before 2.0.02.0.0Patch availableGHSA-66h8-3g48-6hx8
  • Apache Airflow Providers Edge3 VendorApache Affected before 2.0.0 Fixed in 2.0.0 Patch available CNA
  • apache-airflow-providers-edge3 (PyPI) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-66h8-3g48-6hx8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:apache-airflow-providers-edge3:*:*:*:*:*:*:*:*before 2.0.0VulnerableApache
  • cpe:2.3:a:apache:apache-airflow-providers-edge3:*:*:*:*:*:*:*:* Versions before 2.0.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Airflow Providers Edge3 (Apache Software Foundation) Fixed in 2.0.0
  • Fix · GHSA-66h8-3g48-6hx8 apache-airflow-providers-edge3 (PyPI) Fixed in 2.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67895
  2. 2026-10-03 Alias added: GHSA-66h8-3g48-6hx8

References

Sources