Read the docs
TI-2025-41982 Aliases CVE-2025-68434

opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation

Priority HIGH 73CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. Starting in version 3.4.0 and prior to version 3.4.2, a Cross-Site Request Forgery (CSRF) vulnerability exists in the application's filter configuration. The CSRF protection mechanism was **explicitly disabled**, allowing the application to process state-changing requests (POST) without verifying a valid CSRF token. An unauthenticated remote attacker can exploit this by hosting a malicious web page. If a logged-in administrator visits this page, their browser is forced to send unauthorized requests to the application. A successful exploit allows the attacker to silently create a new Administrator account with full privileges, leading to a complete takeover of the system and loss of confidentiality, integrity, and availability. The vulnerability has been patched in version 3.4.2. The fix re-enables the CSRF filter in `app/Config/Filters.php` and resolves associated AJAX race conditions by adjusting token regeneration settings. As a workaround, administrators can manually re-enable the CSRF filter in `app/Config/Filters.php` by uncommenting the protection line. However, this is not recommended without applying the full patch, as it may cause functionality breakage in the Sales module due to token synchronization issues.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00281 20th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed opensourcepos (opensourcepos): 3.4.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opensourceposopensourcepos3.4.0 to before 3.4.23.4.2Patch availableCNA
  • opensourcepos Vendoropensourcepos Affected 3.4.0 to before 3.4.2 Fixed in 3.4.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:*3.4.0 to before 3.4.2Vulnerableopensourcepos
  • cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:* Versions 3.4.0 to before 3.4.2 Vulnerable ·opensourcepos

Remediation

  • Fix · CNA opensourcepos (opensourcepos) Fixed in 3.4.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68434

References

  • TI-2026-25347 Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality CVSS 3.1HIGH 8.8
  • TI-2025-41728 opensourcepos has a Cross-site Scripting vulnerability CVSS 3.1HIGH 8.1
  • TI-2025-43027 An issue in OpenSourcePOS v3.4.1 allows attackers to execute arbitrary code via returning a crafted AJAX response. CVSS 3.1HIGH 7.4
  • TI-2025-41087 A Cross-site scripting (XSS) vulnerability in Create/Update Customer(s) in Open Source… CVSS 3.1HIGH 7.2
  • TI-2025-41086 A Cross-site scripting (XSS) vulnerability in Create/Update Item(s) Module in Open Source… CVSS 3.1HIGH 7.2
  • TI-2026-26109 Open Source Point of Sale has an IDOR in Password Change (Home) CVSS 3.1MEDIUM 6.5
See all 18 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences