Dark Reader gives users the ability to request style sheets from local web servers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-346.
Summary
Dark Reader is an accessibility browser extension that makes web pages colors dark. The dynamic dark mode feature of the extension works by analyzing the colors of web pages found in CSS style sheet files. In order to analyze cross-origin style sheets (stored on websites different from the original web page), Dark Reader requests such files via a background worker, ensuring the request is performed with no credentials and that the content type of the response is a CSS file. Prior to Dark Reader 4.9.117, this style content was assigned to an HTML Style Element in order to parse and loop through style declarations, and also stored in page's Session Storage for performance gains. This could allow a website author to request a style sheet from a locally running web server, for example by having a link pointing to `http[:]//localhost[:]8080/style[.]css`. The brute force of the host name, port and file name would be unlikely due to performance impact, that would cause the browser tab to hang shortly, but it could be possible to request a style sheet if the full URL was known in advance. As per December 18, 2025 there is no known exploit of the issue. The problem has been fixed in version 4.9.117 on December 3, 2025. The style sheets are now parsed using modern Constructed Style Sheets API and the contents of cross-origin style sheets is no longer stored in page's Session Storage. Version 4.9.118 (December 8, 2025) restricts cross-origin requests to localhost aliases, IP addresses, hosts with ports and non-HTTPS resources. The absolute majority of users have received an update 4.1.117 or 4.9.118 automatically within a week. However users must ensure their automatic updates are not blocked and they are using the latest version of the extension by going to chrome://extensions or about:addons pages in browser settings. Users utilizing manual builds must upgrade to version 4.9.118 and above. Developers using `darkreader` NPM package for their own websites are likely not affected, but must ensure the function passed to `setFetchMethod()` for performing cross-origin requests works within the intended scope. Developers using custom forks of earlier versions of Dark Reader to build other extensions or integrating into their apps or browsers must ensure they perform cross-origin requests safely and the responses are not accessible outside of the app or extension.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| darkreader | darkreader | before 4.9.117 | 4.9.117 | Patch available | CNA |
| — | darkreader (npm) | before 4.9.117 | 4.9.117 | Patch available | GHSA-x369-mcw8-8rvj |
- darkreader Vendordarkreader Affected before 4.9.117 Fixed in 4.9.117 Patch available CNA
- darkreader (npm) Vendor— Affected before 4.9.117 Fixed in 4.9.117 Patch available GHSA-x369-mcw8-8rvj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:darkreader:darkreader:*:*:*:*:*:*:*:* | before 4.9.117 | Vulnerable | darkreader |
- cpe:2.3:a:darkreader:darkreader:*:*:*:*:*:*:*:* Versions before 4.9.117 Vulnerable ·darkreader
Remediation
- Fix · CNA darkreader (darkreader) Fixed in 4.9.117
- Fix · GHSA-x369-mcw8-8rvj darkreader (npm) Fixed in 4.9.117 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68467
- 2026-10-03 Alias added: GHSA-x369-mcw8-8rvj
References
Sources
- CVE-2025-68467 · CVE Program
- CVE-2025-68467 · NVD
- FIRST EPSS
- GHSA-x369-mcw8-8rvj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences