Signal K Server Vulnerable to Remote Code Execution via Malicious npm Package
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Signal K Server is a server application that runs on a central hub in a boat. Versions prior to 2.19.0 of the appstore interface allow administrators to install npm packages through a REST API endpoint. While the endpoint validates that the package name exists in the npm registry as a known plugin or webapp, the version parameter accepts arbitrary npm version specifiers including URLs. npm supports installing packages from git repositories, GitHub shorthand syntax, and HTTP/HTTPS URLs pointing to tarballs. When npm installs a package, it can automatically execute any `postinstall` script defined in `package.json`, enabling arbitrary code execution. The vulnerability exists because npm's version specifier syntax is extremely flexible, and the SignalK code passes the version parameter directly to npm without sanitization. An attacker with admin access can install a package from an attacker-controlled source containing a malicious `postinstall` script. Version 2.19.0 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SignalK | signalk-server | before 2.19.0 | 2.19.0 | Patch available | CNA |
| — | signalk-server (npm) | before 2.9.0 | 2.9.0 | Patch available | GHSA-93jc-vqqc-vvvh |
- signalk-server VendorSignalK Affected before 2.19.0 Fixed in 2.19.0 Patch available CNA
- signalk-server (npm) Vendor— Affected before 2.9.0 Fixed in 2.9.0 Patch available GHSA-93jc-vqqc-vvvh
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:signalk:signal_k_server:*:*:*:*:*:*:*:* | before 2.19.0 | Vulnerable | SignalK |
| cpe:2.3:a:signalk:signal_k_server:2.19.0:beta1:*:*:*:*:*:* | 2.19.0 beta1 | Vulnerable | SignalK |
| cpe:2.3:a:signalk:signal_k_server:2.19.0:beta2:*:*:*:*:*:* | 2.19.0 beta2 | Vulnerable | SignalK |
| cpe:2.3:a:signalk:signal_k_server:2.19.0:beta3:*:*:*:*:*:* | 2.19.0 beta3 | Vulnerable | SignalK |
| cpe:2.3:a:signalk:signal_k_server:2.19.0:beta4:*:*:*:*:*:* | 2.19.0 beta4 | Vulnerable | SignalK |
- cpe:2.3:a:signalk:signal_k_server:*:*:*:*:*:*:*:* Versions before 2.19.0 Vulnerable ·SignalK
- cpe:2.3:a:signalk:signal_k_server:2.19.0:beta1:*:*:*:*:*:* Versions 2.19.0 beta1 Vulnerable ·SignalK
- cpe:2.3:a:signalk:signal_k_server:2.19.0:beta2:*:*:*:*:*:* Versions 2.19.0 beta2 Vulnerable ·SignalK
- cpe:2.3:a:signalk:signal_k_server:2.19.0:beta3:*:*:*:*:*:* Versions 2.19.0 beta3 Vulnerable ·SignalK
- cpe:2.3:a:signalk:signal_k_server:2.19.0:beta4:*:*:*:*:*:* Versions 2.19.0 beta4 Vulnerable ·SignalK
Remediation
- Fix · CNA signalk-server (SignalK) Fixed in 2.19.0
- Fix · GHSA-93jc-vqqc-vvvh signalk-server (npm) Fixed in 2.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68619
- 2026-10-03 Alias added: GHSA-93jc-vqqc-vvvh
References
More SignalK Signal K Server vulnerabilities
- TI-2026-26300 signalk-server: Privilege Escalation by Admin Role Injection via /enableSecurity CVSS 3.1CRITICAL 9.4
- TI-2025-40835 Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.7
- TI-2025-42138 Signal K Server vulnerable to JWT Token Theft via WebSocket Enumeration and Unauthenticated Polling CVSS 3.1CRITICAL 9.1
- TI-2026-30295 Signal K Server's WebSocket Login Endpoint Lacks Rate Limiting (Credential Brute-Force) CVSS 4.0HIGH 8.7
- TI-2025-42657 Signal K Server Vulnerable to Access Request Spoofing CVSS 3.1HIGH 8.8
- TI-2026-18939 RCE - Command Injection in Signal K set-system-time plugin CVSS 3.1CRITICAL 10.0
Sources
- CVE-2025-68619 · CVE Program
- CVE-2025-68619 · NVD
- FIRST EPSS
- GHSA-93jc-vqqc-vvvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences