Read the docs
TI-2025-42676 Aliases CVE-2025-69222

LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions

Priority HIGH 72CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

LibreChat is a ChatGPT clone with additional features. Version 0.8.1-rc2 is prone to a server-side request forgery (SSRF) vulnerability due to missing restrictions of the Actions feature in the default configuration. LibreChat enables users to configure agents with predefined instructions and actions that can interact with remote services via OpenAPI specifications, supporting various HTTP methods, parameters, and authentication methods including custom headers. By default, there are no restrictions on accessible services, which means agents can also access internal components like the RAG API included in the default Docker Compose setup. This issue is fixed in version 0.8.1-rc2.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.04593 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
danny-avilaLibreChat>= 0.8.1-rc2, 0.8.2-rc2—No fix listedCNA
  • LibreChat Vendordanny-avila Affected >= 0.8.1-rc2, 0.8.2-rc2 Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:librechat:librechat:0.8.1:-:*:*:*:*:*:*0.8.1Vulnerabledanny-avila
cpe:2.3:a:librechat:librechat:0.8.1:rc1:*:*:*:*:*:*0.8.1 rc1Vulnerabledanny-avila
  • cpe:2.3:a:librechat:librechat:0.8.1:-:*:*:*:*:*:* Versions 0.8.1 Vulnerable ·danny-avila
  • cpe:2.3:a:librechat:librechat:0.8.1:rc1:*:*:*:*:*:* Versions 0.8.1 rc1 Vulnerable ·danny-avila

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-69222

References

  • TI-2026-25134 LibreChat Exfiltrates Server Secrets via MCP Server URL Injection CVSS 3.1CRITICAL 9.6
  • TI-2026-17862 LibreChat MCP Stdio Remote Command Execution CVSS 3.1CRITICAL 9.9
  • TI-2026-38976 LibreChat: Missing Resource Parameter Validation in MCP OAuth Flow CVSS 3.1CRITICAL 9.3
  • TI-2024-27763 LibreChat through 0.7.4-rc1 has incorrect access control for message updates. CVSS 3.1CRITICAL 9.8
  • TI-2024-10347 Path Traversal in danny-avila/librechat CVSS 3.0HIGH 8.8
  • TI-2026-25682 In LibreChat 0.8.1-rc2, a logged-in user obtains a JWT for both the LibreChat API and the RAG API. CVSS 3.1CRITICAL 9.0
See all 50 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences