serverless MCP Server vulnerable to command injection in list-projects tool
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
The Serverless Framework is a framework for using AWS Lambda and other managed cloud services to build applications. Starting in version 4.29.0 and prior to version 4.29.3, a command injection vulnerability exists in the Serverless Framework's built-in MCP server package (@serverless/mcp). This vulnerability only affects users of the experimental MCP server feature (serverless mcp), which represents less than 0.1% of Serverless Framework users. The core Serverless Framework CLI and deployment functionality are not affected. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Version 4.29.3 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| serverless | serverless | 4.29.0 to before 4.29.3 | 4.29.3 | Patch available | CNA |
| — | serverless (npm) | 4.29.0 to before 4.29.3 | 4.29.3 | Patch available | GHSA-rwc2-f344-q6w6 |
- serverless Vendorserverless Affected 4.29.0 to before 4.29.3 Fixed in 4.29.3 Patch available CNA
- serverless (npm) Vendor— Affected 4.29.0 to before 4.29.3 Fixed in 4.29.3 Patch available GHSA-rwc2-f344-q6w6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:serverless:serverless:*:*:*:*:*:*:*:* | 4.29.0 to before 4.29.3 | Vulnerable | serverless |
- cpe:2.3:a:serverless:serverless:*:*:*:*:*:*:*:* Versions 4.29.0 to before 4.29.3 Vulnerable ·serverless
Remediation
- Fix · CNA serverless (serverless) Fixed in 4.29.3
- Fix · GHSA-rwc2-f344-q6w6 serverless (npm) Fixed in 4.29.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-69256
- 2026-10-03 Alias added: GHSA-rwc2-f344-q6w6
References
Sources
- CVE-2025-69256 · CVE Program
- CVE-2025-69256 · NVD
- FIRST EPSS
- GHSA-rwc2-f344-q6w6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences