FUXA v1.2.7 contains a hard-coded credential vulnerability in server/api/jwt-helper.js.
Priority MEDIUM 53CWE-798Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-798.
Summary
FUXA v1.2.7 contains a hard-coded credential vulnerability in server/api/jwt-helper.js. The application uses a hard-coded secret key to sign and verify JWT Tokens. This allows remote attackers to forge valid admin tokens and bypass authentication to gain full administrative access.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02174 82nd percentileScored 2026-11-07
Fix Fixed @frangoteam/fuxa (npm): 1.3.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | @frangoteam/fuxa (npm) | before 1.3.0 | 1.3.0 | Patch available | GHSA-c8m8-3jcr-6rj5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- @frangoteam/fuxa (npm) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-c8m8-3jcr-6rj5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:frangoteam:fuxa:1.2.7:*:*:*:*:*:*:* | 1.2.7 | Vulnerable | frangoteam |
- cpe:2.3:a:frangoteam:fuxa:1.2.7:*:*:*:*:*:*:* Versions 1.2.7 Vulnerable ·frangoteam
Remediation
- Fix · GHSA-c8m8-3jcr-6rj5 @frangoteam/fuxa (npm) Fixed in 1.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-69971
- 2026-10-03 Alias added: GHSA-c8m8-3jcr-6rj5
References
More frangoteam Fuxa vulnerabilities
- TI-2025-42978 FUXA 1.2.8 and prior contains an Authentication Bypass vulnerability leading to Remote… CVSS 3.1CRITICAL 9.8
- TI-2023-16709 A remote command execution (RCE) vulnerability in the /api/runscript endpoint of FUXA… CVSS 3.1CRITICAL 9.8
- TI-2023-15187 FUXA <= 1.1.12 is vulnerable to SQL Injection via /api/signin. CVSS 3.1CRITICAL 9.8
- TI-2023-15186 FUXA <= 1.1.12 is vulnerable to Local via Inclusion via /api/download. CVSS 3.1HIGH 7.5
- TI-2023-15185 A SQL Injection attack in FUXA <= 1.1.12 allows exfiltration of confidential information from the database. CVSS 3.1HIGH 7.5
- TI-2026-20969 FUXA Unauthenticated Remote Arbitrary Scheduler Write CVSS 4.0CRITICAL 9.3
Sources
- CVE-2025-69971 · CVE Program
- CVE-2025-69971 · NVD
- FIRST EPSS
- GHSA-c8m8-3jcr-6rj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences