Read the docs
TI-2025-43236 Aliases CVE-2025-71086GHSA-mqvv-vjpm-cprh

net: rose: fix invalid array index in rose_kill_by_device()

Priority LOW 33CWE-129Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-129 and the CVSS impact.

Summary

In the Linux kernel, the following vulnerability has been resolved: net: rose: fix invalid array index in rose_kill_by_device() rose_kill_by_device() collects sockets into a local array[] and then iterates over them to disconnect sockets bound to a device being brought down. The loop mistakenly indexes array[cnt] instead of array[i]. For cnt < ARRAY_SIZE(array), this reads an uninitialized entry; for cnt == ARRAY_SIZE(array), it is an out-of-bounds read. Either case can lead to an invalid socket pointer dereference and also leaks references taken via sock_hold(). Fix the index to use i.

Why it matters now

EPSS 0.00147 3rd percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.10.248, 5.15.198, 6.1.160 +6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux5.10.206 to before 5.10.248; 5.15.146 to before 5.15.198; 6.1.70 to before 6.1.160; 6.6.9 to before 6.6.120; 4.19.304 to before 4.20; 5.4.266 to before 5.55.10.248, 5.15.198, 6.1.160, 6.6.120, 4.20, 5.5Patch availableCNA
LinuxLinux6.7 and later5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.4, 6.19Patch availableCNA
  • Linux VendorLinux Affected 5.10.206 to before 5.10.248; 5.15.146 to before 5.15.198; 6.1.70 to before 6.1.160; 6.6.9 to before 6.6.120; 4.19.304 to before 4.20; 5.4.266 to before 5.5 Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 4.20, 5.5 Patch available CNA
  • Linux VendorLinux Affected 6.7 and later Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.4, 6.19 Patch available CNA

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*4.19.304 to before 4.20; 5.4.266 to before 5.5; 5.10.206 to before 5.10.248; 5.15.146 to before 5.15.198; 6.1.70 to before 6.1.160; 6.6.9 to before 6.6.120; 6.7.1 to before 6.12.64; 6.13 to before 6.18.4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.7:-:*:*:*:*:*:*6.7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:*6.19 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:*6.19 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:*6.19 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:*6.19 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:*6.19 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:*6.19 rc6VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:*6.19 rc7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:*6.19 rc8VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19.304 to before 4.20; 5.4.266 to before 5.5; 5.10.206 to before 5.10.248; 5.15.146 to before 5.15.198; 6.1.70 to before 6.1.160; 6.6.9 to before 6.6.120; 6.7.1 to before 6.12.64; 6.13 to before 6.18.4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.7:-:*:*:*:*:*:* Versions 6.7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* Versions 6.19 rc8 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 4.20, 5.5
  • Fix · CNA Linux (Linux) Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.4, 6.19

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-71086
  2. 2026-10-03 Alias added: GHSA-mqvv-vjpm-cprh

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources