platform/x86: hp-bioscfg: Fix out-of-bounds array access in ACPI package parsing
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: platform/x86: hp-bioscfg: Fix out-of-bounds array access in ACPI package parsing The hp_populate_*_elements_from_package() functions in the hp-bioscfg driver contain out-of-bounds array access vulnerabilities. These functions parse ACPI packages into internal data structures using a for loop with index variable 'elem' that iterates through enum_obj/integer_obj/order_obj/password_obj/string_obj arrays. When processing multi-element fields like PREREQUISITES and ENUM_POSSIBLE_VALUES, these functions read multiple consecutive array elements using expressions like 'enum_obj[elem + reqs]' and 'enum_obj[elem + pos_values]' within nested loops. The bug is that the bounds check only validated elem, but did not consider the additional offset when accessing elem + reqs or elem + pos_values. The fix changes the bounds check to validate the actual accessed index.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.6 and later | 6.6.120, 6.12.64, 6.18.4, 6.19 | Patch available | CNA |
- Linux VendorLinux Affected 6.6 and later Fixed in 6.6.120, 6.12.64, 6.18.4, 6.19 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.6.1 to before 6.6.120; 6.7 to before 6.12.64; 6.13 to before 6.18.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:-:*:*:*:*:*:* | 6.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* | 6.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* | 6.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* | 6.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* | 6.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* | 6.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* | 6.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* | 6.19 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* | 6.19 rc8 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.6.1 to before 6.6.120; 6.7 to before 6.12.64; 6.13 to before 6.18.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:-:*:*:*:*:*:* Versions 6.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* Versions 6.19 rc8 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.6.120, 6.12.64, 6.18.4, 6.19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-71101
- 2026-10-03 Alias added: GHSA-r28f-pmvp-8355
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-71101 · CVE Program
- CVE-2025-71101 · NVD
- FIRST EPSS
- GHSA-r28f-pmvp-8355 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-71101 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences