usb: typec: ucsi: Handle incorrect num_connectors capability
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: usb: typec: ucsi: Handle incorrect num_connectors capability The UCSI spec states that the num_connectors field is 7 bits, and the 8th bit is reserved and should be set to zero. Some buggy FW has been known to set this bit, and it can lead to a system not booting. Flag that the FW is not behaving correctly, and auto-fix the value so that the system boots correctly. Found on Lenovo P1 G8 during Linux enablement program. The FW will be fixed, but seemed worth addressing in case it hit platforms that aren't officially Linux supported.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.13 and later | 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.3, 6.19 | Patch available | CNA |
- Linux VendorLinux Affected 4.13 and later Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.3, 6.19 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.13.1 to before 5.10.248; 5.11 to before 5.15.198; 5.16 to before 6.1.160; 6.2 to before 6.6.120; 6.7 to before 6.12.64; 6.13 to before 6.18.3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.13:-:*:*:*:*:*:* | 4.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* | 6.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* | 6.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* | 6.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* | 6.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* | 6.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* | 6.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* | 6.19 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* | 6.19 rc8 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.13.1 to before 5.10.248; 5.11 to before 5.15.198; 5.16 to before 6.1.160; 6.2 to before 6.6.120; 6.7 to before 6.12.64; 6.13 to before 6.18.3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.13:-:*:*:*:*:*:* Versions 4.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* Versions 6.19 rc8 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.3, 6.19
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Not affected: 1 product
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2025-71108
- 2026-10-03 Alias added: GHSA-6q3j-74vv-fx6w
- 2026-10-19 Weakness changed · CISA ADP
References
Patch 7
- https://git.kernel.org/stable/c/07c8d2a109d847775b3b4e2c3294c8e1eea75432
- https://git.kernel.org/stable/c/58941bbb0050e365a98c64f1fc4a9a0ac127dba6
- https://git.kernel.org/stable/c/f72f97d0aee4a993a35f2496bca5efd24827235d
- https://git.kernel.org/stable/c/914605b0de8128434eafc9582445306830748b93
- https://git.kernel.org/stable/c/3042a57a8e8bce4a3100c3f6f03dc372aab24943
- https://git.kernel.org/stable/c/132fe187e0d940f388f839fe2cde9b84106ad20d
- https://git.kernel.org/stable/c/30cd2cb1abf4c4acdb1ddb468c946f68939819fb
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-71108 · CVE Program
- CVE-2025-71108 · NVD
- FIRST EPSS
- GHSA-6q3j-74vv-fx6w · GitHub Advisory Database · CC BY 4.0
- CVE-2025-71108 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences