parisc: Do not reprogram affinitiy on ASP chip
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: parisc: Do not reprogram affinitiy on ASP chip The ASP chip is a very old variant of the GSP chip and is used e.g. in HP 730 workstations. When trying to reprogram the affinity it will crash with a HPMC as the relevant registers don't seem to be at the usual location. Let's avoid the crash by checking the sversion. Also note, that reprogramming isn't necessary either, as the HP730 is a just a single-CPU machine.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.111 to before 5.10.248; 5.15.34 to before 5.15.198; 4.14.276 to before 4.15; 4.19.238 to before 4.20; 5.4.189 to before 5.5; 5.16.20 to before 5.17; 5.17.3 to before 5.18 | 5.10.248, 5.15.198, 4.15, 4.20, 5.5, 5.17, 5.18 | Patch available | CNA |
| Linux | Linux | 5.18 and later | 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.3, 6.19 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.111 to before 5.10.248; 5.15.34 to before 5.15.198; 4.14.276 to before 4.15; 4.19.238 to before 4.20; 5.4.189 to before 5.5; 5.16.20 to before 5.17; 5.17.3 to before 5.18 Fixed in 5.10.248, 5.15.198, 4.15, 4.20, 5.5, 5.17, 5.18 Patch available CNA
- Linux VendorLinux Affected 5.18 and later Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.3, 6.19 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14.276 to before 4.15; 4.19.238 to before 4.20; 5.4.189 to before 5.5; 5.10.111 to before 5.10.248; 5.15.34 to before 5.15.198; 5.16.20 to before 5.17; 5.17.3 to before 5.18; 5.18.1 to before 6.1.160; 6.2 to before 6.6.120; 6.7 to before 6.12.64; 6.13 to before 6.18.3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:-:*:*:*:*:*:* | 5.18 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* | 6.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* | 6.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* | 6.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* | 6.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* | 6.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* | 6.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* | 6.19 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* | 6.19 rc8 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.276 to before 4.15; 4.19.238 to before 4.20; 5.4.189 to before 5.5; 5.10.111 to before 5.10.248; 5.15.34 to before 5.15.198; 5.16.20 to before 5.17; 5.17.3 to before 5.18; 5.18.1 to before 6.1.160; 6.2 to before 6.6.120; 6.7 to before 6.12.64; 6.13 to before 6.18.3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:-:*:*:*:*:*:* Versions 5.18 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* Versions 6.19 rc8 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.248, 5.15.198, 4.15, 4.20, 5.5, 5.17, 5.18
- Fix · CNA Linux (Linux) Fixed in 5.10.248, 5.15.198, 6.1.160, 6.6.120, 6.12.64, 6.18.3, 6.19
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-71121
- 2026-10-03 Alias added: GHSA-cvgw-6fq9-4498
References
Patch 7
- https://git.kernel.org/stable/c/845a92b74cf7a730200532ecb4482981cec9d006
- https://git.kernel.org/stable/c/7a146f34e5be96330467397c9fd9d3d851b2cbbe
- https://git.kernel.org/stable/c/4d0858bbeea12a50bfb32137f74d4b74917ebadd
- https://git.kernel.org/stable/c/e09fd2eb6d4c993ee9eaae556cb51e30ec1042df
- https://git.kernel.org/stable/c/60560d13ff368415c96a0c1247bea16d427c0641
- https://git.kernel.org/stable/c/c8f810e20f4bbe50b49f73429d9fa6efad00623e
- https://git.kernel.org/stable/c/dca7da244349eef4d78527cafc0bf80816b261f5
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-71121 · CVE Program
- CVE-2025-71121 · NVD
- FIRST EPSS
- GHSA-cvgw-6fq9-4498 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-71121 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences