Read the docs
TI-2025-43560 Aliases GHSA-9x4v-xfq5-m8x5

Better Auth URL parameter HTML Injection (Reflected Cross-Site scripting)

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

### Summary The better-auth `/api/auth/error` page was vulnerable to HTML injection, resulting in a reflected cross-site scripting (XSS) vulnerability. ### Details The value of `error` URL parameter was reflected as HTML on the error page: https://github.com/better-auth/better-auth/blob/05ada0b79dbcac93cc04ceb79b23ca598d07830c/packages/better-auth/src/api/routes/error.ts#L81 ### Impact An attacker who exploited this vulnerability by coercing a user to visit a specially-crafted URL could execute arbitrary JavaScript in the context of the user's browser.

Why it matters now

Fix Fixed better-auth (npm): 1.1.16

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—better-auth (npm)0.0.2 to before 1.1.161.1.16Patch availableGHSA-9x4v-xfq5-m8x5
  • better-auth (npm) Vendor— Affected 0.0.2 to before 1.1.16 Fixed in 1.1.16 Patch available GHSA-9x4v-xfq5-m8x5

Remediation

  • Fix · GHSA-9x4v-xfq5-m8x5 better-auth (npm) Fixed in 1.1.16 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-9x4v-xfq5-m8x5

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences