Read the docs
TI-2025-43566 Aliases GHSA-8rgj-285w-qcq4

Unknown vulnerability in Coinbase Wallet SDK

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact There is a security vulnerability in outdated versions of Coinbase Wallet SDK. This does not directly affect users' keys, smart contracts, or funds. ### Patches Please update to version >= 4.3.0.

Why it matters now

Fix Fixed @coinbase/wallet-sdk (npm): 4.3.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@coinbase/wallet-sdk (npm)4.0.0-beta.0 to before 4.3.04.3.0Patch availableGHSA-8rgj-285w-qcq4
  • @coinbase/wallet-sdk (npm) Vendor— Affected 4.0.0-beta.0 to before 4.3.0 Fixed in 4.3.0 Patch available GHSA-8rgj-285w-qcq4

Remediation

  • Fix · GHSA-8rgj-285w-qcq4 @coinbase/wallet-sdk (npm) Fixed in 4.3.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-8rgj-285w-qcq4

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences